USN-3713-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3713-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3713-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3713-1
Related
Published
2018-07-11T16:42:23.406200Z
Modified
2018-07-11T16:42:23.406200Z
Summary
cups vulnerabilities
Details

It was discovered that CUPS incorrectly handled certain print jobs with invalid usernames. A remote attacker could possibly use this issue to cause CUPS to crash, resulting in a denial of service. This issue only affected Ubuntu 14.04 LTS, Ubuntu 17.10 and Ubuntu 18.04 LTS. (CVE-2017-18248)

Dan Bastone discovered that the CUPS dnssd backend incorrectly handled certain environment variables. A local attacker could possibly use this issue to escalate privileges. (CVE-2018-4180)

Eric Rafaloff and John Dunlap discovered that CUPS incorrectly handled certain include directives. A local attacker could possibly use this issue to read arbitrary files. (CVE-2018-4181)

Dan Bastone discovered that the CUPS AppArmor profile incorrectly confined the dnssd backend. A local attacker could possibly use this issue to escape confinement. (CVE-2018-6553)

References

Affected packages

Ubuntu:18.04:LTS / cups

Package

Name
cups

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.2.7-1ubuntu2.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libcups2": "2.2.7-1ubuntu2.1",
            "libcupsppdc1": "2.2.7-1ubuntu2.1",
            "cups-ipp-utils": "2.2.7-1ubuntu2.1",
            "cups": "2.2.7-1ubuntu2.1",
            "cups-client": "2.2.7-1ubuntu2.1",
            "libcupsimage2-dev": "2.2.7-1ubuntu2.1",
            "libcupsmime1": "2.2.7-1ubuntu2.1",
            "cups-common": "2.2.7-1ubuntu2.1",
            "libcupsimage2": "2.2.7-1ubuntu2.1",
            "cups-server-common": "2.2.7-1ubuntu2.1",
            "libcupscgi1": "2.2.7-1ubuntu2.1",
            "cups-core-drivers": "2.2.7-1ubuntu2.1",
            "cups-ppdc": "2.2.7-1ubuntu2.1",
            "cups-bsd": "2.2.7-1ubuntu2.1",
            "cups-daemon": "2.2.7-1ubuntu2.1",
            "libcups2-dev": "2.2.7-1ubuntu2.1"
        }
    ]
}

Ubuntu:14.04:LTS / cups

Package

Name
cups

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.7.2-0ubuntu1.10

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libcups2": "1.7.2-0ubuntu1.10",
            "libcupsmime1-dev": "1.7.2-0ubuntu1.10",
            "libcupsppdc1": "1.7.2-0ubuntu1.10",
            "libcupscgi1-dev": "1.7.2-0ubuntu1.10",
            "cups": "1.7.2-0ubuntu1.10",
            "cups-client": "1.7.2-0ubuntu1.10",
            "libcupsimage2-dev": "1.7.2-0ubuntu1.10",
            "libcupsmime1": "1.7.2-0ubuntu1.10",
            "cups-common": "1.7.2-0ubuntu1.10",
            "libcupsimage2": "1.7.2-0ubuntu1.10",
            "cups-server-common": "1.7.2-0ubuntu1.10",
            "libcupscgi1": "1.7.2-0ubuntu1.10",
            "libcupsppdc1-dev": "1.7.2-0ubuntu1.10",
            "cups-core-drivers": "1.7.2-0ubuntu1.10",
            "cups-ppdc": "1.7.2-0ubuntu1.10",
            "cups-bsd": "1.7.2-0ubuntu1.10",
            "cups-daemon": "1.7.2-0ubuntu1.10",
            "libcups2-dev": "1.7.2-0ubuntu1.10"
        }
    ]
}

Ubuntu:16.04:LTS / cups

Package

Name
cups

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.1.3-4ubuntu0.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libcups2": "2.1.3-4ubuntu0.5",
            "libcupsmime1-dev": "2.1.3-4ubuntu0.5",
            "libcupsppdc1": "2.1.3-4ubuntu0.5",
            "libcupscgi1-dev": "2.1.3-4ubuntu0.5",
            "cups-ipp-utils": "2.1.3-4ubuntu0.5",
            "cups": "2.1.3-4ubuntu0.5",
            "cups-client": "2.1.3-4ubuntu0.5",
            "libcupsimage2-dev": "2.1.3-4ubuntu0.5",
            "libcupsmime1": "2.1.3-4ubuntu0.5",
            "cups-common": "2.1.3-4ubuntu0.5",
            "libcupsimage2": "2.1.3-4ubuntu0.5",
            "cups-server-common": "2.1.3-4ubuntu0.5",
            "libcupscgi1": "2.1.3-4ubuntu0.5",
            "libcupsppdc1-dev": "2.1.3-4ubuntu0.5",
            "cups-core-drivers": "2.1.3-4ubuntu0.5",
            "cups-ppdc": "2.1.3-4ubuntu0.5",
            "cups-bsd": "2.1.3-4ubuntu0.5",
            "cups-daemon": "2.1.3-4ubuntu0.5",
            "libcups2-dev": "2.1.3-4ubuntu0.5"
        }
    ]
}