USN-3720-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3720-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3720-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3720-1
Related
Published
2018-07-23T17:36:44.147140Z
Modified
2018-07-23T17:36:44.147140Z
Summary
python-cryptography vulnerability
Details

It was discovered that python-cryptography incorrectly handled certain inputs. An attacker could possibly use this to get access to sensitive information.

References

Affected packages

Ubuntu:18.04:LTS / python-cryptography

Package

Name
python-cryptography

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.1.4-1ubuntu1.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python-cryptography": "2.1.4-1ubuntu1.2",
            "python-cryptography-doc": "2.1.4-1ubuntu1.2",
            "python3-cryptography": "2.1.4-1ubuntu1.2"
        }
    ]
}