USN-3744-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3744-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3744-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3744-1
Related
Published
2018-08-16T13:09:23.296653Z
Modified
2018-08-16T13:09:23.296653Z
Summary
postgresql-10, postgresql-9.3, postgresql-9.5 vulnerabilities
Details

Andrew Krasichkov discovered that the PostgreSQL client library incorrectly reset its internal state between connections. A remote attacker could possibly use this issue to bypass certain client-side connection security features. This issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS. (CVE-2018-10915)

It was discovered that PostgreSQL incorrectly checked authorization on certain statements. A remote attacker could possibly use this issue to read arbitrary server memory or alter certain data. (CVE-2018-10925)

References

Affected packages

Ubuntu:14.04:LTS / postgresql-9.3

Package

Name
postgresql-9.3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
9.3.24-0ubuntu0.14.04

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libecpg6": "9.3.24-0ubuntu0.14.04",
            "postgresql-9.3": "9.3.24-0ubuntu0.14.04",
            "libecpg-dev": "9.3.24-0ubuntu0.14.04",
            "libpq5": "9.3.24-0ubuntu0.14.04",
            "postgresql-plpython3-9.3": "9.3.24-0ubuntu0.14.04",
            "postgresql-doc-9.3": "9.3.24-0ubuntu0.14.04",
            "libpgtypes3": "9.3.24-0ubuntu0.14.04",
            "postgresql-contrib-9.3": "9.3.24-0ubuntu0.14.04",
            "libpq-dev": "9.3.24-0ubuntu0.14.04",
            "postgresql-plpython-9.3": "9.3.24-0ubuntu0.14.04",
            "postgresql-plperl-9.3": "9.3.24-0ubuntu0.14.04",
            "postgresql-server-dev-9.3": "9.3.24-0ubuntu0.14.04",
            "libecpg-compat3": "9.3.24-0ubuntu0.14.04",
            "postgresql-pltcl-9.3": "9.3.24-0ubuntu0.14.04",
            "postgresql-client-9.3": "9.3.24-0ubuntu0.14.04"
        }
    ]
}

Ubuntu:18.04:LTS / postgresql-10

Package

Name
postgresql-10

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
10.5-0ubuntu0.18.04

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libecpg6": "10.5-0ubuntu0.18.04",
            "libecpg-dev": "10.5-0ubuntu0.18.04",
            "postgresql-plperl-10": "10.5-0ubuntu0.18.04",
            "libpq5": "10.5-0ubuntu0.18.04",
            "postgresql-client-10": "10.5-0ubuntu0.18.04",
            "libpq-dev": "10.5-0ubuntu0.18.04",
            "libpgtypes3": "10.5-0ubuntu0.18.04",
            "postgresql-10": "10.5-0ubuntu0.18.04",
            "postgresql-doc-10": "10.5-0ubuntu0.18.04",
            "postgresql-plpython-10": "10.5-0ubuntu0.18.04",
            "libecpg-compat3": "10.5-0ubuntu0.18.04",
            "postgresql-server-dev-10": "10.5-0ubuntu0.18.04",
            "postgresql-pltcl-10": "10.5-0ubuntu0.18.04",
            "postgresql-plpython3-10": "10.5-0ubuntu0.18.04"
        }
    ]
}

Ubuntu:16.04:LTS / postgresql-9.5

Package

Name
postgresql-9.5

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
9.5.14-0ubuntu0.16.04

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libecpg6": "9.5.14-0ubuntu0.16.04",
            "postgresql-doc-9.5": "9.5.14-0ubuntu0.16.04",
            "postgresql-server-dev-9.5": "9.5.14-0ubuntu0.16.04",
            "libecpg-dev": "9.5.14-0ubuntu0.16.04",
            "libpq5": "9.5.14-0ubuntu0.16.04",
            "postgresql-9.5": "9.5.14-0ubuntu0.16.04",
            "postgresql-plpython3-9.5": "9.5.14-0ubuntu0.16.04",
            "libpq-dev": "9.5.14-0ubuntu0.16.04",
            "postgresql-plperl-9.5": "9.5.14-0ubuntu0.16.04",
            "libpgtypes3": "9.5.14-0ubuntu0.16.04",
            "postgresql-pltcl-9.5": "9.5.14-0ubuntu0.16.04",
            "postgresql-plpython-9.5": "9.5.14-0ubuntu0.16.04",
            "libecpg-compat3": "9.5.14-0ubuntu0.16.04",
            "postgresql-client-9.5": "9.5.14-0ubuntu0.16.04",
            "postgresql-contrib-9.5": "9.5.14-0ubuntu0.16.04"
        }
    ]
}