USN-3770-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3770-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3770-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3770-1
Related
Published
2018-09-20T09:18:19.689247Z
Modified
2018-09-20T09:18:19.689247Z
Summary
lcms2 vulnerabilities
Details

Ibrahim El-Sayed discovered that Little CMS incorrectly handled certain files. An attacker could possibly use this issue to cause a denial of service. (CVE-2016-10165)

Quang Nguyen discovered that Little CMS incorrectly handled certain files. An attacker could possibly use this issue to execute arbitrary code. (CVE-2018-16435)

References

Affected packages

Ubuntu:14.04:LTS / lcms2

Package

Name
lcms2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.5-0ubuntu4.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "liblcms2-2": "2.5-0ubuntu4.2",
            "liblcms2-utils": "2.5-0ubuntu4.2",
            "liblcms2-dev": "2.5-0ubuntu4.2"
        }
    ]
}

Ubuntu:18.04:LTS / lcms2

Package

Name
lcms2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.9-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "liblcms2-2": "2.9-1ubuntu0.1",
            "liblcms2-utils": "2.9-1ubuntu0.1",
            "liblcms2-dev": "2.9-1ubuntu0.1"
        }
    ]
}

Ubuntu:16.04:LTS / lcms2

Package

Name
lcms2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6-3ubuntu2.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "liblcms2-2": "2.6-3ubuntu2.1",
            "liblcms2-utils": "2.6-3ubuntu2.1",
            "liblcms2-dev": "2.6-3ubuntu2.1"
        }
    ]
}