USN-3795-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3795-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3795-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3795-1
Related
Published
2018-10-17T12:53:51.468500Z
Modified
2018-10-17T12:53:51.468500Z
Summary
libssh vulnerability
Details

Peter Winter-Smith discovered that libssh incorrectly handled authentication when being used as a server. A remote attacker could use this issue to bypass authentication without any credentials.

References

Affected packages

Ubuntu:14.04:LTS / libssh

Package

Name
libssh

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.6.1-0ubuntu3.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssh-dev": "0.6.1-0ubuntu3.4",
            "libssh-4": "0.6.1-0ubuntu3.4",
            "libssh-doc": "0.6.1-0ubuntu3.4"
        }
    ]
}

Ubuntu:18.04:LTS / libssh

Package

Name
libssh

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.8.0~20170825.94fa1e38-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssh-dev": "0.8.0~20170825.94fa1e38-1ubuntu0.1",
            "libssh-gcrypt-dev": "0.8.0~20170825.94fa1e38-1ubuntu0.1",
            "libssh-gcrypt-4": "0.8.0~20170825.94fa1e38-1ubuntu0.1",
            "libssh-4": "0.8.0~20170825.94fa1e38-1ubuntu0.1",
            "libssh-doc": "0.8.0~20170825.94fa1e38-1ubuntu0.1"
        }
    ]
}

Ubuntu:16.04:LTS / libssh

Package

Name
libssh

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.6.3-4.3ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssh-dev": "0.6.3-4.3ubuntu0.1",
            "libssh-gcrypt-dev": "0.6.3-4.3ubuntu0.1",
            "libssh-gcrypt-4": "0.6.3-4.3ubuntu0.1",
            "libssh-4": "0.6.3-4.3ubuntu0.1",
            "libssh-doc": "0.6.3-4.3ubuntu0.1"
        }
    ]
}