USN-3831-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-3831-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3831-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3831-2
Published
2018-12-06T18:21:21.977092Z
Modified
2018-12-06T18:21:21.977092Z
Summary
ghostscript regression
Details

USN-3831-1 fixed vulnerabilities in Ghostscript. Ghostscript 9.26 introduced a regression when used with certain options. This update fixes the problem.

Original advisory details:

It was discovered that Ghostscript contained multiple security issues. If a user or automated system were tricked into processing a specially crafted file, a remote attacker could possibly use these issues to access arbitrary files, execute arbitrary code, or cause a denial of service.

References

Affected packages

Ubuntu:14.04:LTS / ghostscript

Package

Name
ghostscript

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
9.26~dfsg+0-0ubuntu0.14.04.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgs-dev": "9.26~dfsg+0-0ubuntu0.14.04.3",
            "libgs9-common": "9.26~dfsg+0-0ubuntu0.14.04.3",
            "ghostscript": "9.26~dfsg+0-0ubuntu0.14.04.3",
            "ghostscript-doc": "9.26~dfsg+0-0ubuntu0.14.04.3",
            "ghostscript-x": "9.26~dfsg+0-0ubuntu0.14.04.3",
            "libgs9": "9.26~dfsg+0-0ubuntu0.14.04.3"
        }
    ]
}

Ubuntu:18.04:LTS / ghostscript

Package

Name
ghostscript

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
9.26~dfsg+0-0ubuntu0.18.04.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgs-dev": "9.26~dfsg+0-0ubuntu0.18.04.3",
            "libgs9-common": "9.26~dfsg+0-0ubuntu0.18.04.3",
            "ghostscript": "9.26~dfsg+0-0ubuntu0.18.04.3",
            "ghostscript-doc": "9.26~dfsg+0-0ubuntu0.18.04.3",
            "ghostscript-x": "9.26~dfsg+0-0ubuntu0.18.04.3",
            "libgs9": "9.26~dfsg+0-0ubuntu0.18.04.3"
        }
    ]
}

Ubuntu:16.04:LTS / ghostscript

Package

Name
ghostscript

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
9.26~dfsg+0-0ubuntu0.16.04.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libgs-dev": "9.26~dfsg+0-0ubuntu0.16.04.3",
            "libgs9-common": "9.26~dfsg+0-0ubuntu0.16.04.3",
            "ghostscript": "9.26~dfsg+0-0ubuntu0.16.04.3",
            "ghostscript-doc": "9.26~dfsg+0-0ubuntu0.16.04.3",
            "ghostscript-x": "9.26~dfsg+0-0ubuntu0.16.04.3",
            "libgs9": "9.26~dfsg+0-0ubuntu0.16.04.3"
        }
    ]
}