USN-3839-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3839-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3839-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3839-1
Related
Published
2018-12-06T13:54:27.313253Z
Modified
2018-12-06T13:54:27.313253Z
Summary
wavpack vulnerabilities
Details

It was discovered that WavPack incorrectly handled certain WAV files. An attacker could possibly use this issue to cause a denial of service. (CVE-2018-19840, CVE-2018-19841)

References

Affected packages

Ubuntu:14.04:LTS / wavpack

Package

Name
wavpack

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.70.0-1ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libwavpack-dev": "4.70.0-1ubuntu0.2",
            "libwavpack1": "4.70.0-1ubuntu0.2",
            "wavpack": "4.70.0-1ubuntu0.2"
        }
    ]
}

Ubuntu:18.04:LTS / wavpack

Package

Name
wavpack

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.1.0-2ubuntu1.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libwavpack-dev": "5.1.0-2ubuntu1.2",
            "libwavpack1": "5.1.0-2ubuntu1.2",
            "wavpack": "5.1.0-2ubuntu1.2"
        }
    ]
}

Ubuntu:16.04:LTS / wavpack

Package

Name
wavpack

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.75.2-2ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libwavpack-dev": "4.75.2-2ubuntu0.2",
            "libwavpack1": "4.75.2-2ubuntu0.2",
            "wavpack": "4.75.2-2ubuntu0.2"
        }
    ]
}