USN-3858-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3858-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3858-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3858-1
Related
Published
2019-01-15T11:37:38.038452Z
Modified
2019-01-15T11:37:38.038452Z
Summary
haproxy vulnerabilities
Details

It was discovered that HAProxy incorrectly handled certain requests. An attacker could possibly use this to expose sensitive information. (CVE-2018-20102)

It was discovered that HAProxy incorrectly handled certain requests. A attacker could possibly use this issue to cause a denial of service. This issue only affected Ubuntu 18.04 LTS and Ubuntu 18.10. (CVE-2018-20103, CVE-2018-20615)

References

Affected packages

Ubuntu:18.04:LTS / haproxy

Package

Name
haproxy

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.8.8-1ubuntu0.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "haproxy": "1.8.8-1ubuntu0.3",
            "haproxy-doc": "1.8.8-1ubuntu0.3",
            "vim-haproxy": "1.8.8-1ubuntu0.3"
        }
    ]
}

Ubuntu:16.04:LTS / haproxy

Package

Name
haproxy

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6.3-1ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "haproxy": "1.6.3-1ubuntu0.2",
            "haproxy-doc": "1.6.3-1ubuntu0.2",
            "vim-haproxy": "1.6.3-1ubuntu0.2"
        }
    ]
}