USN-3860-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3860-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3860-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3860-1
Related
Published
2019-01-15T16:06:06.346973Z
Modified
2019-01-15T16:06:06.346973Z
Summary
libcaca vulnerabilities
Details

It was discovered that libcaca incorrectly handled certain images. An attacker could possibly use this issue to cause a denial of service. (CVE-2018-20544)

It was discovered that libcaca incorrectly handled certain images. An attacker could possibly use this issue to execute arbitrary code. (CVE-2018-20545, CVE-2018-20548, CVE-2018-20459)

It was discovered that libcaca incorrectly handled certain images. An attacker could possibly use this issue to access sensitive information. (CVE-2018-20546, CVE-2018-20547)

References

Affected packages

Ubuntu:14.04:LTS / libcaca

Package

Name
libcaca

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.99.beta18-1ubuntu5.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libcaca-dev": "0.99.beta18-1ubuntu5.1",
            "caca-utils": "0.99.beta18-1ubuntu5.1",
            "libcaca0": "0.99.beta18-1ubuntu5.1"
        }
    ]
}

Ubuntu:18.04:LTS / libcaca

Package

Name
libcaca

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.99.beta19-2ubuntu0.18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libcaca-dev": "0.99.beta19-2ubuntu0.18.04.1",
            "caca-utils": "0.99.beta19-2ubuntu0.18.04.1",
            "libcaca0": "0.99.beta19-2ubuntu0.18.04.1"
        }
    ]
}

Ubuntu:16.04:LTS / libcaca

Package

Name
libcaca

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.99.beta19-2ubuntu0.16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libcaca-dev": "0.99.beta19-2ubuntu0.16.04.1",
            "caca-utils": "0.99.beta19-2ubuntu0.16.04.1",
            "libcaca0": "0.99.beta19-2ubuntu0.16.04.1"
        }
    ]
}