USN-3912-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3912-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3912-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3912-1
Related
Published
2019-03-20T18:33:58.646291Z
Modified
2019-03-20T18:33:58.646291Z
Summary
gdk-pixbuf vulnerability
Details

It was discovered that the GDK-PixBuf library did not properly handle certain BMP images. If an user or automated system were tricked into opening a specially crafted BMP file, a remote attacker could use this flaw to cause GDK-PixBuf to crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:16.04:LTS / gdk-pixbuf

Package

Name
gdk-pixbuf

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.32.2-1ubuntu1.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "gir1.2-gdkpixbuf-2.0": "2.32.2-1ubuntu1.6",
            "libgdk-pixbuf2.0-0": "2.32.2-1ubuntu1.6",
            "libgdk-pixbuf2.0-common": "2.32.2-1ubuntu1.6",
            "libgdk-pixbuf2.0-0-udeb": "2.32.2-1ubuntu1.6",
            "libgdk-pixbuf2.0-dev": "2.32.2-1ubuntu1.6",
            "libgdk-pixbuf2.0-doc": "2.32.2-1ubuntu1.6"
        }
    ]
}