USN-3914-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-3914-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3914-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3914-2
Published
2019-04-17T18:13:15.874050Z
Modified
2019-04-17T18:13:15.874050Z
Summary
ntfs-3g update
Details

USN-3914-1 fixed vulnerabilities in NTFS-3G. As an additional hardening measure, this update removes the setuid bit from the ntfs-3g binary.

Original advisory details:

A heap buffer overflow was discovered in NTFS-3G when executing it with a relative mount point path that is too long. A local attacker could potentially exploit this to execute arbitrary code as the administrator.

References

Affected packages

Ubuntu:18.04:LTS / ntfs-3g

Package

Name
ntfs-3g

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2017.3.23-2ubuntu0.18.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ntfs-3g": "1:2017.3.23-2ubuntu0.18.04.2",
            "ntfs-3g-dev": "1:2017.3.23-2ubuntu0.18.04.2",
            "libntfs-3g88": "1:2017.3.23-2ubuntu0.18.04.2",
            "ntfs-3g-udeb": "1:2017.3.23-2ubuntu0.18.04.2"
        }
    ]
}

Ubuntu:16.04:LTS / ntfs-3g

Package

Name
ntfs-3g

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:2015.3.14AR.1-1ubuntu0.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ntfs-3g": "1:2015.3.14AR.1-1ubuntu0.3",
            "ntfs-3g-dev": "1:2015.3.14AR.1-1ubuntu0.3",
            "ntfs-3g-udeb": "1:2015.3.14AR.1-1ubuntu0.3"
        }
    ]
}