USN-3945-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3945-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3945-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3945-1
Related
Published
2019-04-11T12:59:47.613196Z
Modified
2019-04-11T12:59:47.613196Z
Summary
ruby1.9.1, ruby2.0, ruby2.3, ruby2.5 vulnerabilities
Details

It was discovered that Ruby incorrectly handled certain RubyGems. An attacker could possibly use this issue to execute arbitrary commands. (CVE-2019-8320)

It was discovered that Ruby incorrectly handled certain inputs. An attacker could possibly use this issue to execute arbitrary code. (CVE-2019-8321, CVE-2019-8322, CVE-2019-8323, CVE-2019-8324, CVE-2019-8325)

References

Affected packages

Ubuntu:14.04:LTS / ruby1.9.1

Package

Name
ruby1.9.1

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.9.3.484-2ubuntu1.14

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ri1.9.1": "1.9.3.484-2ubuntu1.14",
            "libtcltk-ruby1.9.1": "1.9.3.484-2ubuntu1.14",
            "libruby1.9.1": "1.9.3.484-2ubuntu1.14",
            "ruby1.9.1-dev": "1.9.3.484-2ubuntu1.14",
            "ruby1.9.3": "1.9.3.484-2ubuntu1.14",
            "ruby1.9.1-full": "1.9.3.484-2ubuntu1.14",
            "ruby1.9.1-examples": "1.9.3.484-2ubuntu1.14",
            "ruby1.9.1": "1.9.3.484-2ubuntu1.14"
        }
    ]
}

Ubuntu:14.04:LTS / ruby2.0

Package

Name
ruby2.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.0.0.484-1ubuntu2.13

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ruby2.0-tcltk": "2.0.0.484-1ubuntu2.13",
            "ruby2.0": "2.0.0.484-1ubuntu2.13",
            "libruby2.0": "2.0.0.484-1ubuntu2.13",
            "ruby2.0-doc": "2.0.0.484-1ubuntu2.13",
            "ruby2.0-dev": "2.0.0.484-1ubuntu2.13"
        }
    ]
}

Ubuntu:18.04:LTS / ruby2.5

Package

Name
ruby2.5

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.5.1-1ubuntu1.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ruby2.5": "2.5.1-1ubuntu1.2",
            "libruby2.5": "2.5.1-1ubuntu1.2",
            "ruby2.5-dev": "2.5.1-1ubuntu1.2",
            "ruby2.5-doc": "2.5.1-1ubuntu1.2"
        }
    ]
}

Ubuntu:16.04:LTS / ruby2.3

Package

Name
ruby2.3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.3.1-2~16.04.12

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "ruby2.3-doc": "2.3.1-2~16.04.12",
            "ruby2.3-dev": "2.3.1-2~16.04.12",
            "ruby2.3-tcltk": "2.3.1-2~16.04.12",
            "libruby2.3": "2.3.1-2~16.04.12",
            "ruby2.3": "2.3.1-2~16.04.12"
        }
    ]
}