USN-3990-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-3990-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3990-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3990-2
Related
Published
2019-07-29T13:43:37.754291Z
Modified
2019-07-29T13:43:37.754291Z
Summary
python-urllib3 vulnerability
Details

USN-3990-1 fixed a vulnerability in urllib3. This update provides the corresponding update for Ubuntu 14.04 ESM.

Original advisory details:

It was discovered that urllib3 incorrectly stripped certain characters from requests. A remote attacker could use this issue to perform CRLF injection. (CVE-2019-11236)

References

Affected packages

Ubuntu:Pro:14.04:LTS / python-urllib3

Package

Name
python-urllib3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.7.1-1ubuntu4.1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "python3-urllib3": "1.7.1-1ubuntu4.1+esm1",
            "python-urllib3-whl": "1.7.1-1ubuntu4.1+esm1",
            "python-urllib3": "1.7.1-1ubuntu4.1+esm1"
        }
    ]
}