USN-3993-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-3993-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-3993-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-3993-1
Related
Published
2019-05-22T12:45:36.874656Z
Modified
2019-05-22T12:45:36.874656Z
Summary
curl vulnerabilities
Details

Wenchao Li discovered that curl incorrectly handled memory in the curlurlset() function. A remote attacker could use this issue to cause curl to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 19.04. (CVE-2019-5435)

It was discovered that curl incorrectly handled memory when receiving data from a TFTP server. A remote attacker could use this issue to cause curl to crash, resulting in a denial of service, or possibly execute arbitrary code. (CVE-2019-5436)

References

Affected packages

Ubuntu:18.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.58.0-2ubuntu3.7

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "curl": "7.58.0-2ubuntu3.7",
            "libcurl4": "7.58.0-2ubuntu3.7",
            "libcurl4-gnutls-dev": "7.58.0-2ubuntu3.7",
            "libcurl3-gnutls": "7.58.0-2ubuntu3.7",
            "libcurl4-doc": "7.58.0-2ubuntu3.7",
            "libcurl3-nss": "7.58.0-2ubuntu3.7",
            "libcurl4-nss-dev": "7.58.0-2ubuntu3.7",
            "libcurl4-openssl-dev": "7.58.0-2ubuntu3.7"
        }
    ]
}

Ubuntu:16.04:LTS / curl

Package

Name
curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.47.0-1ubuntu2.13

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "curl": "7.47.0-1ubuntu2.13",
            "libcurl3": "7.47.0-1ubuntu2.13",
            "libcurl4-gnutls-dev": "7.47.0-1ubuntu2.13",
            "libcurl3-gnutls": "7.47.0-1ubuntu2.13",
            "libcurl4-doc": "7.47.0-1ubuntu2.13",
            "libcurl3-nss": "7.47.0-1ubuntu2.13",
            "libcurl4-nss-dev": "7.47.0-1ubuntu2.13",
            "libcurl4-openssl-dev": "7.47.0-1ubuntu2.13"
        }
    ]
}