USN-4001-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-4001-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4001-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4001-2
Related
Published
2019-05-30T22:57:44.142436Z
Modified
2019-05-30T22:57:44.142436Z
Summary
libseccomp vulnerability
Details

USN-4001-1 fixed a vulnerability in libseccomp. This update provides the corresponding update for Ubuntu 14.04 ESM.

Original advisory details:

Jann Horn discovered that libseccomp did not correctly generate 64-bit syscall argument comparisons with arithmetic operators (LT, GT, LE, GE). An attacker could use this to bypass intended access restrictions for argument-filtered system calls.

References

Affected packages

Ubuntu:Pro:14.04:LTS / libseccomp

Package

Name
libseccomp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.1-0ubuntu0.14.04.2

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "seccomp": "2.4.1-0ubuntu0.14.04.2",
            "libseccomp2": "2.4.1-0ubuntu0.14.04.2",
            "libseccomp-dev": "2.4.1-0ubuntu0.14.04.2"
        }
    ]
}