USN-4015-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4015-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4015-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4015-1
Related
Published
2019-06-11T16:38:56.475170Z
Modified
2019-06-11T16:38:56.475170Z
Summary
dbus vulnerability
Details

Joe Vennix discovered that DBus incorrectly handled DBUSCOOKIESHA1 authentication. A local attacker could possibly use this issue to bypass authentication and connect to DBus servers with elevated privileges.

References

Affected packages

Ubuntu:16.04:LTS / dbus

Package

Name
dbus

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.10.6-1ubuntu3.4

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "dbus-1-doc": "1.10.6-1ubuntu3.4",
            "libdbus-1-3": "1.10.6-1ubuntu3.4",
            "dbus-tests": "1.10.6-1ubuntu3.4",
            "dbus-udeb": "1.10.6-1ubuntu3.4",
            "libdbus-1-3-udeb": "1.10.6-1ubuntu3.4",
            "dbus": "1.10.6-1ubuntu3.4",
            "dbus-x11": "1.10.6-1ubuntu3.4",
            "libdbus-1-dev": "1.10.6-1ubuntu3.4",
            "dbus-user-session": "1.10.6-1ubuntu3.4"
        }
    ]
}

Ubuntu:18.04:LTS / dbus

Package

Name
dbus

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.12.2-1ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "dbus-1-doc": "1.12.2-1ubuntu1.1",
            "libdbus-1-3": "1.12.2-1ubuntu1.1",
            "dbus-tests": "1.12.2-1ubuntu1.1",
            "dbus-udeb": "1.12.2-1ubuntu1.1",
            "libdbus-1-3-udeb": "1.12.2-1ubuntu1.1",
            "dbus": "1.12.2-1ubuntu1.1",
            "dbus-x11": "1.12.2-1ubuntu1.1",
            "libdbus-1-dev": "1.12.2-1ubuntu1.1",
            "dbus-user-session": "1.12.2-1ubuntu1.1"
        }
    ]
}