USN-4065-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4065-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4065-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4065-1
Related
Published
2019-07-18T17:22:23.586956Z
Modified
2019-07-18T17:22:23.586956Z
Summary
squid, squid3 vulnerabilities
Details

It was discovered that Squid incorrectly handled Digest authentication. A remote attacker could possibly use this issue to cause Squid to crash, resulting in a denial of service. (CVE-2019-12525)

It was discovered that Squid incorrectly handled Basic authentication. A remote attacker could use this issue to cause Squid to crash, resulting in a denial of service, or possibly execute arbitrary code. This issue only affected Ubuntu 19.04. (CVE-2019-12527)

It was discovered that Squid incorrectly handled Basic authentication. A remote attacker could possibly use this issue to cause Squid to crash, resulting in a denial of service. (CVE-2019-12529)

References

Affected packages

Ubuntu:16.04:LTS / squid3

Package

Name
squid3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.5.12-1ubuntu7.8

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "squid": "3.5.12-1ubuntu7.8",
            "squid-purge": "3.5.12-1ubuntu7.8",
            "squid-common": "3.5.12-1ubuntu7.8",
            "squid3": "3.5.12-1ubuntu7.8",
            "squid-cgi": "3.5.12-1ubuntu7.8",
            "squidclient": "3.5.12-1ubuntu7.8"
        }
    ]
}

Ubuntu:18.04:LTS / squid3

Package

Name
squid3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.5.27-1ubuntu1.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "squid": "3.5.27-1ubuntu1.3",
            "squid-purge": "3.5.27-1ubuntu1.3",
            "squid-common": "3.5.27-1ubuntu1.3",
            "squid3": "3.5.27-1ubuntu1.3",
            "squid-cgi": "3.5.27-1ubuntu1.3",
            "squidclient": "3.5.27-1ubuntu1.3"
        }
    ]
}