USN-4070-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4070-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4070-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4070-1
Related
Published
2019-07-24T11:34:58.330884Z
Modified
2019-07-24T11:34:58.330884Z
Summary
mysql-5.7 vulnerabilities
Details

Multiple security issues were discovered in MySQL and this update includes a new upstream MySQL version to fix these issues.

Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 19.04 have been updated to MySQL 5.7.27.

In addition to security fixes, the updated packages contain bug fixes, new features, and possibly incompatible changes.

Please see the following for more information: http://dev.mysql.com/doc/relnotes/mysql/5.7/en/news-5-7-27.html https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html

References

Affected packages

Ubuntu:16.04:LTS / mysql-5.7

Package

Name
mysql-5.7

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.7.27-0ubuntu0.16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libmysqlclient20": "5.7.27-0ubuntu0.16.04.1",
            "mysql-testsuite": "5.7.27-0ubuntu0.16.04.1",
            "mysql-server-5.7": "5.7.27-0ubuntu0.16.04.1",
            "mysql-testsuite-5.7": "5.7.27-0ubuntu0.16.04.1",
            "libmysqld-dev": "5.7.27-0ubuntu0.16.04.1",
            "mysql-client-core-5.7": "5.7.27-0ubuntu0.16.04.1",
            "mysql-client": "5.7.27-0ubuntu0.16.04.1",
            "mysql-source-5.7": "5.7.27-0ubuntu0.16.04.1",
            "mysql-client-5.7": "5.7.27-0ubuntu0.16.04.1",
            "libmysqlclient-dev": "5.7.27-0ubuntu0.16.04.1",
            "mysql-common": "5.7.27-0ubuntu0.16.04.1",
            "mysql-server": "5.7.27-0ubuntu0.16.04.1",
            "mysql-server-core-5.7": "5.7.27-0ubuntu0.16.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / mysql-5.7

Package

Name
mysql-5.7

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.7.27-0ubuntu0.18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libmysqlclient20": "5.7.27-0ubuntu0.18.04.1",
            "mysql-testsuite": "5.7.27-0ubuntu0.18.04.1",
            "mysql-server-5.7": "5.7.27-0ubuntu0.18.04.1",
            "mysql-testsuite-5.7": "5.7.27-0ubuntu0.18.04.1",
            "libmysqld-dev": "5.7.27-0ubuntu0.18.04.1",
            "mysql-client-core-5.7": "5.7.27-0ubuntu0.18.04.1",
            "mysql-client": "5.7.27-0ubuntu0.18.04.1",
            "mysql-source-5.7": "5.7.27-0ubuntu0.18.04.1",
            "mysql-client-5.7": "5.7.27-0ubuntu0.18.04.1",
            "libmysqlclient-dev": "5.7.27-0ubuntu0.18.04.1",
            "mysql-server": "5.7.27-0ubuntu0.18.04.1",
            "mysql-server-core-5.7": "5.7.27-0ubuntu0.18.04.1"
        }
    ]
}