USN-4078-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4078-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4078-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4078-1
Related
Published
2019-07-30T16:50:18.523029Z
Modified
2019-07-30T16:50:18.523029Z
Summary
openldap vulnerabilities
Details

It was discovered that OpenLDAP incorrectly handled rootDN delegation. A database administrator could use this issue to request authorization as an identity from another database, contrary to expectations. (CVE-2019-13057)

It was discovered that OpenLDAP incorrectly handled SASL authentication and session encryption. After a first SASL bind was completed, it was possible to obtain access by performing simple binds, contrary to expectations. (CVE-2019-13565)

References

Affected packages

Ubuntu:18.04:LTS / openldap

Package

Name
openldap

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.45+dfsg-1ubuntu1.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "slapd-smbk5pwd": "2.4.45+dfsg-1ubuntu1.3",
            "libldap-common": "2.4.45+dfsg-1ubuntu1.3",
            "libldap-2.4-2": "2.4.45+dfsg-1ubuntu1.3",
            "slapd": "2.4.45+dfsg-1ubuntu1.3",
            "libldap2-dev": "2.4.45+dfsg-1ubuntu1.3",
            "ldap-utils": "2.4.45+dfsg-1ubuntu1.3"
        }
    ]
}

Ubuntu:16.04:LTS / openldap

Package

Name
openldap

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.42+dfsg-2ubuntu3.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libldap-2.4-2": "2.4.42+dfsg-2ubuntu3.6",
            "libldap2-dev": "2.4.42+dfsg-2ubuntu3.6",
            "slapd": "2.4.42+dfsg-2ubuntu3.6",
            "slapd-smbk5pwd": "2.4.42+dfsg-2ubuntu3.6",
            "ldap-utils": "2.4.42+dfsg-2ubuntu3.6"
        }
    ]
}