USN-4096-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4096-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4096-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4096-1
Related
  • CVE-2019-1125
Published
2019-08-13T16:24:56.374057Z
Modified
2019-08-13T16:24:56.374057Z
Summary
linux-aws, linux-aws-hwe vulnerability
Details

Andrei Vlad Lutas and Dan Lutas discovered that some x86 processors incorrectly handle SWAPGS instructions during speculative execution. A local attacker could use this to expose sensitive information (kernel memory).

References

Affected packages

Ubuntu:18.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1045.47

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-aws": "4.15.0.1045.44",
            "linux-image-4.15.0-1045-aws": "4.15.0-1045.47"
        }
    ]
}

Ubuntu:16.04:LTS / linux-aws-hwe

Package

Name
linux-aws-hwe

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1045.47~16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-aws-hwe": "4.15.0.1045.45",
            "linux-image-4.15.0-1045-aws": "4.15.0-1045.47~16.04.1"
        }
    ]
}