USN-4155-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4155-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4155-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4155-1
Related
Published
2019-10-15T14:12:49.376416Z
Modified
2019-10-15T14:12:49.376416Z
Summary
aspell vulnerability
Details

It was discovered that Aspell incorrectly handled certain inputs. An attacker could potentially access sensitive information.

References

Affected packages

Ubuntu:16.04:LTS / aspell

Package

Name
aspell

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.60.7~20110707-3ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libpspell-dev": "0.60.7~20110707-3ubuntu0.1",
            "libaspell15": "0.60.7~20110707-3ubuntu0.1",
            "aspell": "0.60.7~20110707-3ubuntu0.1",
            "libaspell-dev": "0.60.7~20110707-3ubuntu0.1",
            "aspell-doc": "0.60.7~20110707-3ubuntu0.1"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / aspell

Package

Name
aspell

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.60.7~20110707-1ubuntu1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libpspell-dev": "0.60.7~20110707-1ubuntu1+esm1",
            "libaspell15": "0.60.7~20110707-1ubuntu1+esm1",
            "aspell": "0.60.7~20110707-1ubuntu1+esm1",
            "libaspell-dev": "0.60.7~20110707-1ubuntu1+esm1",
            "aspell-doc": "0.60.7~20110707-1ubuntu1+esm1"
        }
    ]
}

Ubuntu:18.04:LTS / aspell

Package

Name
aspell

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.60.7~20110707-4ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libpspell-dev": "0.60.7~20110707-4ubuntu0.1",
            "libaspell15": "0.60.7~20110707-4ubuntu0.1",
            "aspell": "0.60.7~20110707-4ubuntu0.1",
            "libaspell-dev": "0.60.7~20110707-4ubuntu0.1",
            "aspell-doc": "0.60.7~20110707-4ubuntu0.1"
        }
    ]
}