USN-4166-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4166-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4166-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4166-1
Related
Published
2019-10-28T17:19:18.134026Z
Modified
2019-10-28T17:19:18.134026Z
Summary
php7.0, php7.2, php7.3 vulnerability
Details

It was discovered that PHP incorrectly handled certain paths when being used in FastCGI configurations. A remote attacker could possibly use this issue to execute arbitrary code.

References

Affected packages

Ubuntu:16.04:LTS / php7.0

Package

Name
php7.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.0.33-0ubuntu0.16.04.7

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "php7.0-cgi": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-pspell": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-enchant": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-xsl": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-readline": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-mysql": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-dba": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-intl": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-zip": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-soap": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-mcrypt": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-gd": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-odbc": "7.0.33-0ubuntu0.16.04.7",
            "libphp7.0-embed": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-interbase": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-recode": "7.0.33-0ubuntu0.16.04.7",
            "php7.0": "7.0.33-0ubuntu0.16.04.7",
            "libapache2-mod-php7.0": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-imap": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-snmp": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-gmp": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-ldap": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-opcache": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-pgsql": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-curl": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-json": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-fpm": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-xmlrpc": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-xml": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-dev": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-tidy": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-sqlite3": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-mbstring": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-cli": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-bcmath": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-bz2": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-sybase": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-common": "7.0.33-0ubuntu0.16.04.7",
            "php7.0-phpdbg": "7.0.33-0ubuntu0.16.04.7"
        }
    ]
}

Ubuntu:18.04:LTS / php7.2

Package

Name
php7.2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.2.24-0ubuntu0.18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "php7.2-ldap": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-mbstring": "7.2.24-0ubuntu0.18.04.1",
            "libapache2-mod-php7.2": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-opcache": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-intl": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-bz2": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-gmp": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-sybase": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-bcmath": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-odbc": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-snmp": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-pgsql": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-recode": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-phpdbg": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-interbase": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-cgi": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-sqlite3": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-tidy": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-json": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-xmlrpc": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-fpm": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-curl": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-cli": "7.2.24-0ubuntu0.18.04.1",
            "php7.2": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-xsl": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-zip": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-xml": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-common": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-dba": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-readline": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-mysql": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-imap": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-enchant": "7.2.24-0ubuntu0.18.04.1",
            "libphp7.2-embed": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-gd": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-pspell": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-soap": "7.2.24-0ubuntu0.18.04.1",
            "php7.2-dev": "7.2.24-0ubuntu0.18.04.1"
        }
    ]
}