USN-4194-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-4194-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4194-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4194-2
Related
Published
2019-12-03T18:34:11.440831Z
Modified
2019-12-03T18:34:11.440831Z
Summary
postgresql-common vulnerability
Details

USN-4194-1 fixed a vulnerability in postgresql-common. This update provides the corresponding update for Ubuntu 14.04 ESM.

Original advisory details:

Rich Mirch discovered that the postgresql-common pg_ctlcluster script incorrectly handled directory creation. A local attacker could possibly use this issue to escalate privileges.

References

Affected packages

Ubuntu:Pro:14.04:LTS / postgresql-common

Package

Name
postgresql-common

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
154ubuntu1.1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "postgresql-common": "154ubuntu1.1+esm1",
            "postgresql-doc": "9.3+154ubuntu1.1+esm1",
            "postgresql-client": "9.3+154ubuntu1.1+esm1",
            "postgresql-client-common": "154ubuntu1.1+esm1",
            "postgresql-server-dev-all": "154ubuntu1.1+esm1",
            "postgresql-contrib": "9.3+154ubuntu1.1+esm1",
            "postgresql": "9.3+154ubuntu1.1+esm1"
        }
    ]
}