USN-4198-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4198-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4198-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4198-1
Related
Published
2019-11-21T19:29:42.619307Z
Modified
2019-11-21T19:29:42.619307Z
Summary
djvulibre vulnerabilities
Details

It was discovered that DjVuLibre incorrectly handled certain memory operations. If a user or automated system were tricked into processing a specially crafted DjVu file, a remote attacker could cause applications to hang or crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:18.04:LTS / djvulibre

Package

Name
djvulibre

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.5.27.1-8ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "djview3": "3.5.27.1-8ubuntu0.1",
            "libdjvulibre21": "3.5.27.1-8ubuntu0.1",
            "djvulibre-bin": "3.5.27.1-8ubuntu0.1",
            "djvulibre-desktop": "3.5.27.1-8ubuntu0.1",
            "libdjvulibre-text": "3.5.27.1-8ubuntu0.1",
            "djvuserve": "3.5.27.1-8ubuntu0.1",
            "djview": "3.5.27.1-8ubuntu0.1",
            "libdjvulibre-dev": "3.5.27.1-8ubuntu0.1"
        }
    ]
}

Ubuntu:16.04:LTS / djvulibre

Package

Name
djvulibre

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.5.27.1-5ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "djview3": "3.5.27.1-5ubuntu0.1",
            "libdjvulibre21": "3.5.27.1-5ubuntu0.1",
            "djvulibre-bin": "3.5.27.1-5ubuntu0.1",
            "djvulibre-desktop": "3.5.27.1-5ubuntu0.1",
            "libdjvulibre-text": "3.5.27.1-5ubuntu0.1",
            "djvuserve": "3.5.27.1-5ubuntu0.1",
            "djview": "3.5.27.1-5ubuntu0.1",
            "libdjvulibre-dev": "3.5.27.1-5ubuntu0.1"
        }
    ]
}