USN-4247-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-4247-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4247-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4247-2
Published
2020-01-22T23:11:22.866615Z
Modified
2020-01-22T23:11:22.866615Z
Summary
python-apt regression
Details

USN-4247-1 fixed vulnerabilities in python-apt. The updated packages caused a regression when attempting to upgrade to a new Ubuntu release. This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

It was discovered that python-apt would still use MD5 hashes to validate certain downloaded packages. If a remote attacker were able to perform a machine-in-the-middle attack, this flaw could potentially be used to install altered packages. (CVE-2019-15795)

It was discovered that python-apt could install packages from untrusted repositories, contrary to expectations. (CVE-2019-15796)

References

Affected packages

Ubuntu:16.04:LTS / python-apt

Package

Name
python-apt

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.0~beta1ubuntu0.16.04.8

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3-apt": "1.1.0~beta1ubuntu0.16.04.8",
            "python-apt-common": "1.1.0~beta1ubuntu0.16.04.8",
            "python-apt": "1.1.0~beta1ubuntu0.16.04.8",
            "python-apt-dev": "1.1.0~beta1ubuntu0.16.04.8",
            "python-apt-doc": "1.1.0~beta1ubuntu0.16.04.8"
        }
    ]
}

Ubuntu:18.04:LTS / python-apt

Package

Name
python-apt

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6.5ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python3-apt": "1.6.5ubuntu0.2",
            "python-apt-common": "1.6.5ubuntu0.2",
            "python-apt": "1.6.5ubuntu0.2",
            "python-apt-dev": "1.6.5ubuntu0.2",
            "python-apt-doc": "1.6.5ubuntu0.2"
        }
    ]
}