USN-4276-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4276-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4276-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4276-1
Related
Published
2020-02-11T14:52:48.740368Z
Modified
2020-02-11T14:52:48.740368Z
Summary
Yubico PIV Tool vulnerabilities
Details

It was discovered that libykpiv, a supporting library of the Yubico PIV Tool and YubiKey PIV Manager, mishandled specially crafted input. An attacker with a custom-made, malicious USB device could potentially execute arbitrary code on a computer running the Yubico PIV Tool or Yubikey PIV Manager.

References

Affected packages

Ubuntu:18.04:LTS / yubico-piv-tool

Package

Name
yubico-piv-tool

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.4.2-2ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libykpiv-dev": "1.4.2-2ubuntu0.1",
            "libykpiv1": "1.4.2-2ubuntu0.1",
            "ykcs11": "1.4.2-2ubuntu0.1",
            "yubico-piv-tool": "1.4.2-2ubuntu0.1"
        }
    ]
}