USN-4327-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4327-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4327-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4327-1
Related
Published
2020-04-09T12:11:24.976705Z
Modified
2020-04-09T12:11:24.976705Z
Summary
libssh vulnerability
Details

Yasheng Yang discovered that libssh incorrectly handled AES-CTR ciphers. A remote attacker could possibly use this issue to cause libssh to crash, resulting in a denial of service.

References

Affected packages

Ubuntu:18.04:LTS / libssh

Package

Name
libssh

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.8.0~20170825.94fa1e38-1ubuntu0.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libssh-dev": "0.8.0~20170825.94fa1e38-1ubuntu0.6",
            "libssh-gcrypt-dev": "0.8.0~20170825.94fa1e38-1ubuntu0.6",
            "libssh-gcrypt-4": "0.8.0~20170825.94fa1e38-1ubuntu0.6",
            "libssh-4": "0.8.0~20170825.94fa1e38-1ubuntu0.6",
            "libssh-doc": "0.8.0~20170825.94fa1e38-1ubuntu0.6"
        }
    ]
}