USN-4342-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4342-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4342-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4342-1
Related
Published
2020-04-30T17:52:52.217676Z
Modified
2020-04-30T17:52:52.217676Z
Summary
linux, linux-aws, linux-azure, linux-azure-5.3, linux-gcp, linux-gcp-5.3, linux-gke-5.3, linux-hwe, linux-kvm, linux-oracle, linux-oracle-5.3, linux-raspi2, linux-raspi2-5.3 vulnerabilities
Details

Al Viro discovered that the Linux kernel for s390x systems did not properly perform page table upgrades for kernel sections that use secondary address mode. A local attacker could use this to cause a denial of service (system crash) or execute arbitrary code. (CVE-2020-11884)

It was discovered that the Intel Wi-Fi driver in the Linux kernel did not properly check for errors in some situations. A local attacker could possibly use this to cause a denial of service (system crash). (CVE-2019-16234)

Tristan Madani discovered that the block I/O tracing implementation in the Linux kernel contained a race condition. A local attacker could use this to cause a denial of service (system crash) or possibly expose sensitive information. (CVE-2019-19768)

It was discovered that the vhost net driver in the Linux kernel contained a stack buffer overflow. A local attacker with the ability to perform ioctl() calls on /dev/vhost-net could use this to cause a denial of service (system crash). (CVE-2020-10942)

It was discovered that the virtual terminal implementation in the Linux kernel contained a race condition. A local attacker could possibly use this to cause a denial of service (system crash) or expose sensitive information. (CVE-2020-8648)

Shijie Luo discovered that the ext4 file system implementation in the Linux kernel did not properly check for a too-large journal size. An attacker could use this to construct a malicious ext4 image that, when mounted, could cause a denial of service (soft lockup). (CVE-2020-8992)

Jordy Zomer discovered that the floppy driver in the Linux kernel did not properly check for errors in some situations. A local attacker could possibly use this to cause a denial of service (system crash) or possibly expose sensitive information. (CVE-2020-9383)

References

Affected packages

Ubuntu:18.04:LTS / linux-azure-5.3

Package

Name
linux-azure-5.3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.3.0-1020.21~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-azure": "5.3.0.1020.20",
            "linux-image-azure-edge": "5.3.0.1020.20",
            "linux-image-5.3.0-1020-azure": "5.3.0-1020.21~18.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gcp-5.3

Package

Name
linux-gcp-5.3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.3.0-1018.19~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.3.0-1018-gcp": "5.3.0-1018.19~18.04.1",
            "linux-image-gcp-edge": "5.3.0.1018.17",
            "linux-image-gcp": "5.3.0.1018.17"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gke-5.3

Package

Name
linux-gke-5.3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.3.0-1018.19~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-gke-5.3": "5.3.0.1018.8",
            "linux-image-5.3.0-1018-gke": "5.3.0-1018.19~18.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / linux-oracle-5.3

Package

Name
linux-oracle-5.3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.3.0-1016.18~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-oracle-edge": "5.3.0.1016.17",
            "linux-image-oracle": "5.3.0.1016.17",
            "linux-image-5.3.0-1016-oracle": "5.3.0-1016.18~18.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / linux-hwe

Package

Name
linux-hwe

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.3.0-51.44~18.04.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.3.0-51-lowlatency": "5.3.0-51.44~18.04.2",
            "linux-image-snapdragon-hwe-18.04": "5.3.0.51.104",
            "linux-image-snapdragon-hwe-18.04-edge": "5.3.0.51.104",
            "linux-image-generic-lpae-hwe-18.04-edge": "5.3.0.51.104",
            "linux-image-lowlatency-hwe-18.04": "5.3.0.51.104",
            "linux-image-5.3.0-51-generic-lpae": "5.3.0-51.44~18.04.2",
            "linux-image-generic-hwe-18.04": "5.3.0.51.104",
            "linux-image-5.3.0-51-generic": "5.3.0-51.44~18.04.2",
            "linux-image-virtual-hwe-18.04-edge": "5.3.0.51.104",
            "linux-image-virtual-hwe-18.04": "5.3.0.51.104",
            "linux-image-generic-hwe-18.04-edge": "5.3.0.51.104",
            "linux-image-generic-lpae-hwe-18.04": "5.3.0.51.104",
            "linux-image-lowlatency-hwe-18.04-edge": "5.3.0.51.104"
        }
    ]
}

Ubuntu:18.04:LTS / linux-raspi2-5.3

Package

Name
linux-raspi2-5.3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.3.0-1023.25~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.3.0-1023-raspi2": "5.3.0-1023.25~18.04.1",
            "linux-image-raspi2-hwe-18.04": "5.3.0.1023.12"
        }
    ]
}