USN-4359-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-4359-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4359-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4359-2
Related
Published
2020-05-28T19:06:37.838168Z
Modified
2020-05-28T19:06:37.838168Z
Summary
apt vulnerability
Details

USN-4359-1 fixed a vulnerability in APT. This update provides the corresponding update for Ubuntu 12.04 ESM and 14.04 ESM.

Original advisory details:

It was discovered that APT incorrectly handled certain filenames during package installation. If an attacker could provide a specially crafted package to be installed by the system administrator, this could cause APT to crash.

References

Affected packages

Ubuntu:Pro:14.04:LTS / apt

Package

Name
apt

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.1ubuntu2.24+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "apt-transport-https": "1.0.1ubuntu2.24+esm1",
            "apt": "1.0.1ubuntu2.24+esm1",
            "libapt-pkg-dev": "1.0.1ubuntu2.24+esm1",
            "libapt-pkg4.12": "1.0.1ubuntu2.24+esm1",
            "libapt-inst1.5": "1.0.1ubuntu2.24+esm1",
            "libapt-pkg-doc": "1.0.1ubuntu2.24+esm1",
            "apt-utils": "1.0.1ubuntu2.24+esm1",
            "apt-doc": "1.0.1ubuntu2.24+esm1"
        }
    ]
}