USN-4374-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4374-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4374-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4374-1
Related
Published
2020-05-27T15:19:10.042490Z
Modified
2020-05-27T15:19:10.042490Z
Summary
unbound vulnerabilities
Details

Lior Shafir, Yehuda Afek, and Anat Bremler-Barr discovered that Unbound incorrectly handled certain queries. A remote attacker could use this issue to perform an amplification attack directed at a target. (CVE-2020-12662)

It was discovered that Unbound incorrectly handled certain malformed answers. A remote attacker could possibly use this issue to cause Unbound to crash, resulting in a denial of service. (CVE-2020-12663)

References

Affected packages

Ubuntu:20.04:LTS / unbound

Package

Name
unbound

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.9.4-2ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libunbound8": "1.9.4-2ubuntu1.1",
            "libunbound-dev": "1.9.4-2ubuntu1.1",
            "unbound-anchor": "1.9.4-2ubuntu1.1",
            "python3-unbound": "1.9.4-2ubuntu1.1",
            "python-unbound": "1.9.4-2ubuntu1.1",
            "unbound-host": "1.9.4-2ubuntu1.1",
            "unbound": "1.9.4-2ubuntu1.1"
        }
    ]
}

Ubuntu:18.04:LTS / unbound

Package

Name
unbound

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.6.7-1ubuntu2.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libunbound2": "1.6.7-1ubuntu2.3",
            "libunbound-dev": "1.6.7-1ubuntu2.3",
            "unbound-anchor": "1.6.7-1ubuntu2.3",
            "python3-unbound": "1.6.7-1ubuntu2.3",
            "python-unbound": "1.6.7-1ubuntu2.3",
            "unbound-host": "1.6.7-1ubuntu2.3",
            "unbound": "1.6.7-1ubuntu2.3"
        }
    ]
}