USN-4426-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4426-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4426-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4426-1
Related
  • CVE-2019-20908
  • CVE-2020-10757
  • CVE-2020-11935
  • CVE-2020-15780
Published
2020-07-27T22:46:40.712386Z
Modified
2020-07-27T22:46:40.712386Z
Summary
linux, linux-aws, linux-aws-hwe, linux-azure, linux-azure-4.15, linux-gcp, linux-gcp-4.15, linux-gke-4.15, linux-hwe, linux-kvm, linux-oem, linux-oracle, linux-raspi2, linux-snapdragon vulnerabilities
Details

Jason A. Donenfeld discovered that the ACPI implementation in the Linux kernel did not properly restrict loading SSDT code from an EFI variable. A privileged attacker could use this to bypass Secure Boot lockdown restrictions and execute arbitrary code in the kernel. (CVE-2019-20908)

Fan Yang discovered that the mremap implementation in the Linux kernel did not properly handle DAX Huge Pages. A local attacker with access to DAX storage could use this to gain administrative privileges. (CVE-2020-10757)

Mauricio Faria de Oliveira discovered that the aufs implementation in the Linux kernel improperly managed inode reference counts in the vfsubdentryopen() method. A local attacker could use this vulnerability to cause a denial of service. (CVE-2020-11935)

Jason A. Donenfeld discovered that the ACPI implementation in the Linux kernel did not properly restrict loading ACPI tables via configfs. A privileged attacker could use this to bypass Secure Boot lockdown restrictions and execute arbitrary code in the kernel. (CVE-2020-15780)

References

Affected packages

Ubuntu:18.04:LTS / linux-gcp-4.15

Package

Name
linux-gcp-4.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1080.90

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1080-gcp": "4.15.0-1080.90",
            "linux-image-gcp-lts-18.04": "4.15.0.1080.96"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gke-4.15

Package

Name
linux-gke-4.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1066.69

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1066-gke": "4.15.0-1066.69",
            "linux-image-gke-4.15": "4.15.0.1066.68",
            "linux-image-gke": "4.15.0.1066.68"
        }
    ]
}

Ubuntu:18.04:LTS / linux-kvm

Package

Name
linux-kvm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1071.72

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1071-kvm": "4.15.0-1071.72",
            "linux-image-kvm": "4.15.0.1071.67"
        }
    ]
}

Ubuntu:18.04:LTS / linux-snapdragon

Package

Name
linux-snapdragon

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1083.91

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {}
    ]
}

Ubuntu:18.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1079.83

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1079-aws": "4.15.0-1079.83",
            "linux-image-aws-lts-18.04": "4.15.0.1079.81"
        }
    ]
}

Ubuntu:18.04:LTS / linux-raspi2

Package

Name
linux-raspi2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1067.71

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-raspi2": "4.15.0.1067.65",
            "linux-image-4.15.0-1067-raspi2": "4.15.0-1067.71"
        }
    ]
}

Ubuntu:18.04:LTS / linux-oracle

Package

Name
linux-oracle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1050.54

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1050-oracle": "4.15.0-1050.54",
            "linux-image-oracle-lts-18.04": "4.15.0.1050.59"
        }
    ]
}

Ubuntu:18.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-112.113

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-112-generic-lpae": "4.15.0-112.113",
            "linux-image-4.15.0-112-lowlatency": "4.15.0-112.113",
            "linux-image-lowlatency-hwe-16.04": "4.15.0.112.100",
            "linux-image-virtual-hwe-16.04-edge": "4.15.0.112.100",
            "linux-image-generic-hwe-16.04": "4.15.0.112.100",
            "linux-image-generic-lpae-hwe-16.04": "4.15.0.112.100",
            "linux-image-lowlatency": "4.15.0.112.100",
            "linux-image-generic-lpae-hwe-16.04-edge": "4.15.0.112.100",
            "linux-image-generic": "4.15.0.112.100",
            "linux-image-4.15.0-112-generic": "4.15.0-112.113",
            "linux-image-lowlatency-hwe-16.04-edge": "4.15.0.112.100",
            "linux-image-virtual": "4.15.0.112.100",
            "linux-image-generic-hwe-16.04-edge": "4.15.0.112.100",
            "linux-image-generic-lpae": "4.15.0.112.100",
            "linux-image-virtual-hwe-16.04": "4.15.0.112.100"
        }
    ]
}

Ubuntu:18.04:LTS / linux-oem

Package

Name
linux-oem

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1093.103

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1093-oem": "4.15.0-1093.103",
            "linux-image-oem": "4.15.0.1093.96"
        }
    ]
}

Ubuntu:18.04:LTS / linux-azure-4.15

Package

Name
linux-azure-4.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1092.102

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1092-azure": "4.15.0-1092.102",
            "linux-image-azure-lts-18.04": "4.15.0.1092.63"
        }
    ]
}

Ubuntu:16.04:LTS / linux-aws-hwe

Package

Name
linux-aws-hwe

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1079.83~16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1079-aws": "4.15.0-1079.83~16.04.1",
            "linux-image-aws-hwe": "4.15.0.1079.76"
        }
    ]
}

Ubuntu:16.04:LTS / linux-hwe

Package

Name
linux-hwe

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-112.113~16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-112-generic-lpae": "4.15.0-112.113~16.04.1",
            "linux-image-virtual-hwe-16.04-edge": "4.15.0.112.114",
            "linux-image-generic-hwe-16.04": "4.15.0.112.114",
            "linux-image-4.15.0-112-lowlatency": "4.15.0-112.113~16.04.1",
            "linux-image-lowlatency-hwe-16.04": "4.15.0.112.114",
            "linux-image-generic-lpae-hwe-16.04": "4.15.0.112.114",
            "linux-image-generic-lpae-hwe-16.04-edge": "4.15.0.112.114",
            "linux-image-4.15.0-112-generic": "4.15.0-112.113~16.04.1",
            "linux-image-lowlatency-hwe-16.04-edge": "4.15.0.112.114",
            "linux-image-generic-hwe-16.04-edge": "4.15.0.112.114",
            "linux-image-oem": "4.15.0.112.114",
            "linux-image-virtual-hwe-16.04": "4.15.0.112.114"
        }
    ]
}

Ubuntu:16.04:LTS / linux-gcp

Package

Name
linux-gcp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1080.90~16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1080-gcp": "4.15.0-1080.90~16.04.1",
            "linux-image-gke": "4.15.0.1080.82",
            "linux-image-gcp": "4.15.0.1080.82"
        }
    ]
}

Ubuntu:16.04:LTS / linux-oracle

Package

Name
linux-oracle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1050.54~16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1050-oracle": "4.15.0-1050.54~16.04.1",
            "linux-image-oracle": "4.15.0.1050.41"
        }
    ]
}

Ubuntu:16.04:LTS / linux-azure

Package

Name
linux-azure

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1092.102~16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-azure": "4.15.0.1092.87",
            "linux-image-azure-edge": "4.15.0.1092.87",
            "linux-image-4.15.0-1092-azure": "4.15.0-1092.102~16.04.1"
        }
    ]
}