USN-4470-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4470-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4470-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4470-1
Related
  • CVE-2017-6318
  • CVE-2020-12861
  • CVE-2020-12862
  • CVE-2020-12863
  • CVE-2020-12864
  • CVE-2020-12865
  • CVE-2020-12866
  • CVE-2020-12867
Published
2020-08-24T17:38:52.498570Z
Modified
2020-08-24T17:38:52.498570Z
Summary
sane-backends vulnerabilities
Details

Kritphong Mongkhonvanit discovered that sane-backends incorrectly handled certain packets. A remote attacker could possibly use this issue to obtain sensitive memory information. This issue only affected Ubuntu 16.04 LTS. (CVE-2017-6318)

It was discovered that sane-backends incorrectly handled certain memory operations. A remote attacker could possibly use this issue to execute arbitrary code. This issue only applied to Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-12861)

It was discovered that sane-backends incorrectly handled certain memory operations. A remote attacker could possibly use this issue to obtain sensitive information. (CVE-2020-12862, CVE-2020-12863)

It was discovered that sane-backends incorrectly handled certain memory operations. A remote attacker could possibly use this issue to obtain sensitive information. This issue only applied to Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-12864)

It was discovered that sane-backends incorrectly handled certain memory operations. A remote attacker could possibly use this issue to execute arbitrary code. (CVE-2020-12865)

It was discovered that sane-backends incorrectly handled certain memory operations. A remote attacker could possibly use this issue to cause a denial of service. This issue only applied to Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-12866)

It was discovered that sane-backends incorrectly handled certain memory operations. A remote attacker could possibly use this issue to cause a denial of service. (CVE-2020-12867)

References

Affected packages

Ubuntu:20.04:LTS / sane-backends

Package

Name
sane-backends

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.29-0ubuntu5.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libsane1": "1.0.29-0ubuntu5.1",
            "sane-utils": "1.0.29-0ubuntu5.1",
            "libsane": "1.0.29-0ubuntu5.1",
            "libsane-common": "1.0.29-0ubuntu5.1",
            "libsane-dev": "1.0.29-0ubuntu5.1"
        }
    ]
}

Ubuntu:18.04:LTS / sane-backends

Package

Name
sane-backends

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.27-1~experimental3ubuntu2.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libsane1": "1.0.27-1~experimental3ubuntu2.3",
            "sane-utils": "1.0.27-1~experimental3ubuntu2.3",
            "libsane-common": "1.0.27-1~experimental3ubuntu2.3",
            "libsane-dev": "1.0.27-1~experimental3ubuntu2.3"
        }
    ]
}

Ubuntu:16.04:LTS / sane-backends

Package

Name
sane-backends

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.25+git20150528-1ubuntu2.16.04.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "sane-utils": "1.0.25+git20150528-1ubuntu2.16.04.3",
            "libsane": "1.0.25+git20150528-1ubuntu2.16.04.3",
            "libsane-common": "1.0.25+git20150528-1ubuntu2.16.04.3",
            "libsane-dev": "1.0.25+git20150528-1ubuntu2.16.04.3"
        }
    ]
}