USN-4471-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4471-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4471-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4471-1
Related
Published
2020-08-24T16:09:50.121409Z
Modified
2020-08-24T16:09:50.121409Z
Summary
net-snmp vulnerabilities
Details

Tobias Neitzel discovered that Net-SNMP incorrectly handled certain symlinks. An attacker could possibly use this issue to access sensitive information. (CVE-2020-15861)

It was discovered that Net-SNMP incorrectly handled certain inputs. An attacker could possibly use this issue to execute arbitrary code. This issue only affected Ubuntu 14.04 ESM, Ubuntu 16.04 LTS, Ubuntu 18.04 LTS, and Ubuntu 20.04 LTS. (CVE-2020-15862)

References

Affected packages

Ubuntu:20.04:LTS / net-snmp

Package

Name
net-snmp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.8+dfsg-2ubuntu2.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "snmpd": "5.8+dfsg-2ubuntu2.3",
            "libsnmp35": "5.8+dfsg-2ubuntu2.3",
            "libsnmp-perl": "5.8+dfsg-2ubuntu2.3",
            "tkmib": "5.8+dfsg-2ubuntu2.3",
            "snmptrapd": "5.8+dfsg-2ubuntu2.3",
            "libsnmp-dev": "5.8+dfsg-2ubuntu2.3",
            "snmp": "5.8+dfsg-2ubuntu2.3",
            "libsnmp-base": "5.8+dfsg-2ubuntu2.3"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / net-snmp

Package

Name
net-snmp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.7.2~dfsg-8.1ubuntu3.3+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libsnmp30": "5.7.2~dfsg-8.1ubuntu3.3+esm1",
            "snmpd": "5.7.2~dfsg-8.1ubuntu3.3+esm1",
            "libsnmp-perl": "5.7.2~dfsg-8.1ubuntu3.3+esm1",
            "tkmib": "5.7.2~dfsg-8.1ubuntu3.3+esm1",
            "snmp": "5.7.2~dfsg-8.1ubuntu3.3+esm1",
            "libsnmp-dev": "5.7.2~dfsg-8.1ubuntu3.3+esm1",
            "python-netsnmp": "5.7.2~dfsg-8.1ubuntu3.3+esm1",
            "libsnmp-base": "5.7.2~dfsg-8.1ubuntu3.3+esm1"
        }
    ]
}

Ubuntu:18.04:LTS / net-snmp

Package

Name
net-snmp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.7.3+dfsg-1.8ubuntu3.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libsnmp30": "5.7.3+dfsg-1.8ubuntu3.5",
            "snmpd": "5.7.3+dfsg-1.8ubuntu3.5",
            "libsnmp-perl": "5.7.3+dfsg-1.8ubuntu3.5",
            "tkmib": "5.7.3+dfsg-1.8ubuntu3.5",
            "snmptrapd": "5.7.3+dfsg-1.8ubuntu3.5",
            "libsnmp-dev": "5.7.3+dfsg-1.8ubuntu3.5",
            "snmp": "5.7.3+dfsg-1.8ubuntu3.5",
            "python-netsnmp": "5.7.3+dfsg-1.8ubuntu3.5",
            "libsnmp-base": "5.7.3+dfsg-1.8ubuntu3.5"
        }
    ]
}

Ubuntu:16.04:LTS / net-snmp

Package

Name
net-snmp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.7.3+dfsg-1ubuntu4.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libsnmp30": "5.7.3+dfsg-1ubuntu4.5",
            "snmpd": "5.7.3+dfsg-1ubuntu4.5",
            "libsnmp-perl": "5.7.3+dfsg-1ubuntu4.5",
            "tkmib": "5.7.3+dfsg-1ubuntu4.5",
            "snmptrapd": "5.7.3+dfsg-1ubuntu4.5",
            "libsnmp-dev": "5.7.3+dfsg-1ubuntu4.5",
            "snmp": "5.7.3+dfsg-1ubuntu4.5",
            "python-netsnmp": "5.7.3+dfsg-1ubuntu4.5",
            "libsnmp-base": "5.7.3+dfsg-1ubuntu4.5"
        }
    ]
}