USN-4478-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-4478-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4478-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4478-2
Related
Published
2022-02-21T17:25:41.107168Z
Modified
2022-02-21T17:25:41.107168Z
Summary
python-rsa vulnerability
Details

USN-4478-1 fixed a vulnerability in Python-RSA. This update provides the corresponding update for Ubuntu 16.04 ESM, Ubuntu 18.04 ESM and Ubuntu 20.04 ESM.

Original advisory details:

It was discovered that Python-RSA incorrectly handled certain ciphertexts. An attacker could possibly use this issue to obtain sensitive information.

References

Affected packages

Ubuntu:Pro:20.04:LTS / python-rsa

Package

Name
python-rsa

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.0-3ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "python3-rsa": "4.0-3ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / python-rsa

Package

Name
python-rsa

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.4.2-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "python3-rsa": "3.4.2-1ubuntu0.1~esm1",
            "python-rsa": "3.4.2-1ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / python-rsa

Package

Name
python-rsa

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.2.3-1.1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "python3-rsa": "3.2.3-1.1ubuntu0.1~esm1",
            "python-rsa": "3.2.3-1.1ubuntu0.1~esm1"
        }
    ]
}