USN-4487-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-4487-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4487-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4487-2
Related
Published
2020-09-08T16:18:57.792533Z
Modified
2020-09-08T16:18:57.792533Z
Summary
libx11 vulnerabilities
Details

USN-4487-1 fixed several vulnerabilities in libx11. This update provides the corresponding update for Ubuntu 12.04 ESM and 14.04 ESM.

Original advisory details:

Todd Carson discovered that libx11 incorrectly handled certain memory operations. A local attacker could possibly use this issue to escalate privileges. (CVE-2020-14344)

Jayden Rivers discovered that libx11 incorrectly handled locales. A local attacker could possibly use this issue to escalate privileges. (CVE-2020-14363)

References

Affected packages

Ubuntu:Pro:14.04:LTS / libx11

Package

Name
libx11

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:1.6.2-1ubuntu2.1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libx11-6-udeb": "2:1.6.2-1ubuntu2.1+esm1",
            "libx11-dev": "2:1.6.2-1ubuntu2.1+esm1",
            "libx11-6": "2:1.6.2-1ubuntu2.1+esm1",
            "libx11-xcb-dev": "2:1.6.2-1ubuntu2.1+esm1",
            "libx11-xcb1": "2:1.6.2-1ubuntu2.1+esm1",
            "libx11-doc": "2:1.6.2-1ubuntu2.1+esm1",
            "libx11-data": "2:1.6.2-1ubuntu2.1+esm1"
        }
    ]
}