USN-4489-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4489-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4489-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4489-1
Related
  • CVE-2020-14386
Published
2020-09-08T07:20:05.005853Z
Modified
2020-09-08T07:20:05.005853Z
Summary
linux, linux-aws, linux-aws-5.3, linux-aws-5.4, linux-aws-hwe, linux-azure, linux-azure-4.15, linux-azure-5.4, linux-gcp, linux-gcp-4.15, linux-gcp-5.4, linux-gke-4.15, linux-gke-5.0, linux-gke-5.3, linux-hwe, linux-hwe-5.4, linux-kvm, linux-oem, linux-oem-osp1, linux-oracle, linux-oracle-5.4, linux-raspi, linux-raspi-5.4, linux-raspi2, linux-raspi2-5.3, linux-snapdragon vulnerability
Details

Or Cohen discovered that the AF_PACKET implementation in the Linux kernel did not properly perform bounds checking in some situations. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code.

References

Affected packages

Ubuntu:18.04:LTS / linux-gke-5.3

Package

Name
linux-gke-5.3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.3.0-1036.38

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.3.0-1036-gke": "5.3.0-1036.38",
            "linux-image-gke-5.3": "5.3.0.1036.20"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gcp-5.4

Package

Name
linux-gcp-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1024.24~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.4.0-1024-gcp": "5.4.0-1024.24~18.04.1",
            "linux-image-gcp-edge": "5.4.0.1024.11",
            "linux-image-gke-5.4": "5.4.0.1024.11",
            "linux-image-gcp": "5.4.0.1024.11"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gke-5.0

Package

Name
linux-gke-5.0

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.0.0-1047.48

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.0.0-1047-gke": "5.0.0-1047.48",
            "linux-image-gke-5.0": "5.0.0.1047.32"
        }
    ]
}

Ubuntu:18.04:LTS / linux-snapdragon

Package

Name
linux-snapdragon

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1086.94

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-snapdragon": "4.15.0.1086.89",
            "linux-image-4.15.0-1086-snapdragon": "4.15.0-1086.94"
        }
    ]
}

Ubuntu:18.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-117.118

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-generic-lpae-hwe-16.04": "4.15.0.117.104",
            "linux-image-lowlatency-hwe-16.04": "4.15.0.117.104",
            "linux-image-4.15.0-117-generic-lpae": "4.15.0-117.118",
            "linux-image-virtual-hwe-16.04-edge": "4.15.0.117.104",
            "linux-image-generic-hwe-16.04": "4.15.0.117.104",
            "linux-image-generic-lpae-hwe-16.04-edge": "4.15.0.117.104",
            "linux-image-lowlatency": "4.15.0.117.104",
            "linux-image-4.15.0-117-lowlatency": "4.15.0-117.118",
            "linux-image-generic": "4.15.0.117.104",
            "linux-image-lowlatency-hwe-16.04-edge": "4.15.0.117.104",
            "linux-image-4.15.0-117-generic": "4.15.0-117.118",
            "linux-image-virtual": "4.15.0.117.104",
            "linux-image-generic-hwe-16.04-edge": "4.15.0.117.104",
            "linux-image-generic-lpae": "4.15.0.117.104",
            "linux-image-virtual-hwe-16.04": "4.15.0.117.104"
        }
    ]
}

Ubuntu:18.04:LTS / linux-aws-5.4

Package

Name
linux-aws-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1024.24~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.4.0-1024-aws": "5.4.0-1024.24~18.04.1",
            "linux-image-aws-edge": "5.4.0.1024.9"
        }
    ]
}

Ubuntu:18.04:LTS / linux-aws-5.3

Package

Name
linux-aws-5.3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.3.0-1035.37

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-aws": "5.3.0.1035.34",
            "linux-image-5.3.0-1035-aws": "5.3.0-1035.37"
        }
    ]
}

Ubuntu:18.04:LTS / linux-azure-4.15

Package

Name
linux-azure-4.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1095.105

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1095-azure": "4.15.0-1095.105",
            "linux-image-azure-lts-18.04": "4.15.0.1095.68"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gcp-4.15

Package

Name
linux-gcp-4.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1083.94

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1083-gcp": "4.15.0-1083.94",
            "linux-image-gcp-lts-18.04": "4.15.0.1083.101"
        }
    ]
}

Ubuntu:18.04:LTS / linux-gke-4.15

Package

Name
linux-gke-4.15

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1069.72

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1069-gke": "4.15.0-1069.72",
            "linux-image-gke-4.15": "4.15.0.1069.73",
            "linux-image-gke": "4.15.0.1069.73"
        }
    ]
}

Ubuntu:18.04:LTS / linux-kvm

Package

Name
linux-kvm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1074.75

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1074-kvm": "4.15.0-1074.75",
            "linux-image-kvm": "4.15.0.1074.70"
        }
    ]
}

Ubuntu:18.04:LTS / linux-hwe-5.4

Package

Name
linux-hwe-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-47.51~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-gkeop-5.4": "5.4.0.47.51~18.04.40",
            "linux-image-5.4.0-47-lowlatency": "5.4.0-47.51~18.04.1",
            "linux-image-snapdragon-hwe-18.04-edge": "5.4.0.47.51~18.04.40",
            "linux-image-generic-lpae-hwe-18.04-edge": "5.4.0.47.51~18.04.40",
            "linux-image-5.4.0-47-generic-lpae": "5.4.0-47.51~18.04.1",
            "linux-image-lowlatency-hwe-18.04": "5.4.0.47.51~18.04.40",
            "linux-image-virtual-hwe-18.04-edge": "5.4.0.47.51~18.04.40",
            "linux-image-generic-hwe-18.04": "5.4.0.47.51~18.04.40",
            "linux-image-lowlatency-hwe-18.04-edge": "5.4.0.47.51~18.04.40",
            "linux-image-5.4.0-47-generic": "5.4.0-47.51~18.04.1",
            "linux-image-virtual-hwe-18.04": "5.4.0.47.51~18.04.40",
            "linux-image-generic-lpae-hwe-18.04": "5.4.0.47.51~18.04.40",
            "linux-image-generic-hwe-18.04-edge": "5.4.0.47.51~18.04.40",
            "linux-image-snapdragon-hwe-18.04": "5.4.0.47.51~18.04.40"
        }
    ]
}

Ubuntu:18.04:LTS / linux-oracle-5.4

Package

Name
linux-oracle-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1024.24~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-oracle-edge": "5.4.0.1024.8",
            "linux-image-5.4.0-1024-oracle": "5.4.0-1024.24~18.04.1",
            "linux-image-oracle": "5.4.0.1024.8"
        }
    ]
}

Ubuntu:18.04:LTS / linux-oem-osp1

Package

Name
linux-oem-osp1

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.0.0-1068.73

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.0.0-1068-oem-osp1": "5.0.0-1068.73",
            "linux-image-oem-osp1": "5.0.0.1068.66"
        }
    ]
}

Ubuntu:18.04:LTS / linux-oracle

Package

Name
linux-oracle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1053.57

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1053-oracle": "4.15.0-1053.57",
            "linux-image-oracle-lts-18.04": "4.15.0.1053.63"
        }
    ]
}

Ubuntu:18.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1082.86

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1082-aws": "4.15.0-1082.86",
            "linux-image-aws-lts-18.04": "4.15.0.1082.84"
        }
    ]
}

Ubuntu:18.04:LTS / linux-raspi2

Package

Name
linux-raspi2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1070.74

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1070-raspi2": "4.15.0-1070.74",
            "linux-image-raspi2": "4.15.0.1070.67"
        }
    ]
}

Ubuntu:18.04:LTS / linux-azure-5.4

Package

Name
linux-azure-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1025.25~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-azure": "5.4.0.1025.8",
            "linux-image-azure-edge": "5.4.0.1025.8",
            "linux-image-5.4.0-1025-azure": "5.4.0-1025.25~18.04.1"
        }
    ]
}

Ubuntu:18.04:LTS / linux-raspi-5.4

Package

Name
linux-raspi-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1018.20~18.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-raspi-hwe-18.04": "5.4.0.1018.22",
            "linux-image-5.4.0-1018-raspi": "5.4.0-1018.20~18.04.1",
            "linux-image-raspi-hwe-18.04-edge": "5.4.0.1018.22"
        }
    ]
}

Ubuntu:18.04:LTS / linux-hwe

Package

Name
linux-hwe

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.3.0-67.61

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-gkeop-5.3": "5.3.0.67.124",
            "linux-image-5.3.0-67-generic": "5.3.0-67.61",
            "linux-image-5.3.0-67-lowlatency": "5.3.0-67.61"
        }
    ]
}

Ubuntu:18.04:LTS / linux-oem

Package

Name
linux-oem

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1096.106

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-oem": "4.15.0.1096.100",
            "linux-image-4.15.0-1096-oem": "4.15.0-1096.106"
        }
    ]
}

Ubuntu:18.04:LTS / linux-raspi2-5.3

Package

Name
linux-raspi2-5.3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.3.0-1033.35

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-raspi2-hwe-18.04": "5.3.0.1033.23",
            "linux-image-5.3.0-1033-raspi2": "5.3.0-1033.35"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / linux-azure

Package

Name
linux-azure

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1095.105~14.04.1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-image-azure": "4.15.0.1095.71",
            "linux-image-4.15.0-1095-azure": "4.15.0-1095.105~14.04.1"
        }
    ]
}

Ubuntu:20.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-47.51

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.4.0-47-lowlatency": "5.4.0-47.51",
            "linux-image-generic-lpae-hwe-18.04-edge": "5.4.0.47.50",
            "linux-image-5.4.0-47-generic-lpae": "5.4.0-47.51",
            "linux-image-lowlatency-hwe-18.04": "5.4.0.47.50",
            "linux-image-virtual-hwe-18.04-edge": "5.4.0.47.50",
            "linux-image-generic-hwe-18.04": "5.4.0.47.50",
            "linux-image-generic-lpae-hwe-20.04": "5.4.0.47.50",
            "linux-image-lowlatency-hwe-18.04-edge": "5.4.0.47.50",
            "linux-image-virtual-hwe-18.04": "5.4.0.47.50",
            "linux-image-5.4.0-47-generic": "5.4.0-47.51",
            "linux-image-oem-osp1": "5.4.0.47.50",
            "linux-image-virtual-hwe-20.04": "5.4.0.47.50",
            "linux-image-generic-lpae-hwe-18.04": "5.4.0.47.50",
            "linux-image-generic-hwe-18.04-edge": "5.4.0.47.50",
            "linux-image-generic-hwe-20.04": "5.4.0.47.50",
            "linux-image-lowlatency": "5.4.0.47.50",
            "linux-image-generic": "5.4.0.47.50",
            "linux-image-lowlatency-hwe-20.04": "5.4.0.47.50",
            "linux-image-virtual": "5.4.0.47.50",
            "linux-image-oem": "5.4.0.47.50",
            "linux-image-generic-lpae": "5.4.0.47.50"
        }
    ]
}

Ubuntu:20.04:LTS / linux-kvm

Package

Name
linux-kvm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1023.23

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-kvm": "5.4.0.1023.21"
        }
    ]
}

Ubuntu:20.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1024.24

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.4.0-1024-aws": "5.4.0-1024.24",
            "linux-image-aws": "5.4.0.1024.25"
        }
    ]
}

Ubuntu:20.04:LTS / linux-raspi

Package

Name
linux-raspi

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1018.20

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-raspi-hwe-18.04": "5.4.0.1018.53",
            "linux-image-5.4.0-1018-raspi": "5.4.0-1018.20",
            "linux-image-raspi2-hwe-18.04-edge": "5.4.0.1018.53",
            "linux-image-raspi2-hwe-18.04": "5.4.0.1018.53",
            "linux-image-raspi-hwe-18.04-edge": "5.4.0.1018.53",
            "linux-image-raspi": "5.4.0.1018.53",
            "linux-image-raspi2": "5.4.0.1018.53"
        }
    ]
}

Ubuntu:20.04:LTS / linux-oracle

Package

Name
linux-oracle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1024.24

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.4.0-1024-oracle": "5.4.0-1024.24",
            "linux-image-oracle": "5.4.0.1024.21"
        }
    ]
}

Ubuntu:20.04:LTS / linux-azure

Package

Name
linux-azure

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1025.25

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-azure": "5.4.0.1025.24",
            "linux-image-5.4.0-1025-azure": "5.4.0-1025.25"
        }
    ]
}

Ubuntu:20.04:LTS / linux-gcp

Package

Name
linux-gcp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1024.24

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-5.4.0-1024-gcp": "5.4.0-1024.24",
            "linux-image-gke": "5.4.0.1024.21",
            "linux-image-gcp": "5.4.0.1024.21"
        }
    ]
}

Ubuntu:16.04:LTS / linux-aws-hwe

Package

Name
linux-aws-hwe

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1082.86~16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1082-aws": "4.15.0-1082.86~16.04.1",
            "linux-image-aws-hwe": "4.15.0.1082.78"
        }
    ]
}

Ubuntu:16.04:LTS / linux-hwe

Package

Name
linux-hwe

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-117.118~16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-lowlatency-hwe-16.04": "4.15.0.117.118",
            "linux-image-virtual-hwe-16.04-edge": "4.15.0.117.118",
            "linux-image-generic-hwe-16.04": "4.15.0.117.118",
            "linux-image-generic-lpae-hwe-16.04-edge": "4.15.0.117.118",
            "linux-image-4.15.0-117-lowlatency": "4.15.0-117.118~16.04.1",
            "linux-image-generic-lpae-hwe-16.04": "4.15.0.117.118",
            "linux-image-lowlatency-hwe-16.04-edge": "4.15.0.117.118",
            "linux-image-4.15.0-117-generic": "4.15.0-117.118~16.04.1",
            "linux-image-4.15.0-117-generic-lpae": "4.15.0-117.118~16.04.1",
            "linux-image-generic-hwe-16.04-edge": "4.15.0.117.118",
            "linux-image-oem": "4.15.0.117.118",
            "linux-image-virtual-hwe-16.04": "4.15.0.117.118"
        }
    ]
}

Ubuntu:16.04:LTS / linux-gcp

Package

Name
linux-gcp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1083.94~16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1083-gcp": "4.15.0-1083.94~16.04.1",
            "linux-image-gke": "4.15.0.1083.84",
            "linux-image-gcp": "4.15.0.1083.84"
        }
    ]
}

Ubuntu:16.04:LTS / linux-oracle

Package

Name
linux-oracle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1053.57~16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-4.15.0-1053-oracle": "4.15.0-1053.57~16.04.1",
            "linux-image-oracle": "4.15.0.1053.43"
        }
    ]
}

Ubuntu:16.04:LTS / linux-azure

Package

Name
linux-azure

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.15.0-1095.105~16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-azure": "4.15.0.1095.89",
            "linux-image-azure-edge": "4.15.0.1095.89",
            "linux-image-4.15.0-1095-azure": "4.15.0-1095.105~16.04.1"
        }
    ]
}