USN-4551-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4551-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4551-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4551-1
Related
Published
2020-09-28T16:41:05.131823Z
Modified
2020-09-28T16:41:05.131823Z
Summary
squid3 vulnerabilities
Details

Alex Rousskov and Amit Klein discovered that Squid incorrectly handled certain Content-Length headers. A remote attacker could possibly use this issue to perform an HTTP request smuggling attack, resulting in cache poisoning. (CVE-2020-15049)

Amit Klein discovered that Squid incorrectly validated certain data. A remote attacker could possibly use this issue to perform an HTTP request smuggling attack, resulting in cache poisoning. (CVE-2020-15810)

Régis Leroy discovered that Squid incorrectly validated certain data. A remote attacker could possibly use this issue to perform an HTTP request splitting attack, resulting in cache poisoning. (CVE-2020-15811)

Lubos Uhliarik discovered that Squid incorrectly handled certain Cache Digest response messages sent by trusted peers. A remote attacker could possibly use this issue to cause Squid to consume resources, resulting in a denial of service. (CVE-2020-24606)

References

Affected packages

Ubuntu:18.04:LTS / squid3

Package

Name
squid3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.5.27-1ubuntu1.9

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "squid": "3.5.27-1ubuntu1.9",
            "squid-purge": "3.5.27-1ubuntu1.9",
            "squid-common": "3.5.27-1ubuntu1.9",
            "squid3": "3.5.27-1ubuntu1.9",
            "squid-cgi": "3.5.27-1ubuntu1.9",
            "squidclient": "3.5.27-1ubuntu1.9"
        }
    ]
}

Ubuntu:16.04:LTS / squid3

Package

Name
squid3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.5.12-1ubuntu7.15

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "squid": "3.5.12-1ubuntu7.15",
            "squid-purge": "3.5.12-1ubuntu7.15",
            "squid-common": "3.5.12-1ubuntu7.15",
            "squid3": "3.5.12-1ubuntu7.15",
            "squid-cgi": "3.5.12-1ubuntu7.15",
            "squidclient": "3.5.12-1ubuntu7.15"
        }
    ]
}