USN-4572-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4572-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4572-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4572-1
Related
Published
2020-10-06T13:26:34.958842Z
Modified
2020-10-06T13:26:34.958842Z
Summary
spice vulnerability
Details

Frediano Ziglio discovered that Spice incorrectly handled QUIC image decoding. A remote attacker could use this to cause Spice to crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:20.04:LTS / spice

Package

Name
spice

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.14.2-4ubuntu3.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libspice-server1": "0.14.2-4ubuntu3.1",
            "libspice-server-dev": "0.14.2-4ubuntu3.1"
        }
    ]
}

Ubuntu:18.04:LTS / spice

Package

Name
spice

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.14.0-1ubuntu2.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libspice-server1": "0.14.0-1ubuntu2.5",
            "libspice-server-dev": "0.14.0-1ubuntu2.5"
        }
    ]
}

Ubuntu:16.04:LTS / spice

Package

Name
spice

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.12.6-4ubuntu0.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libspice-server1": "0.12.6-4ubuntu0.5",
            "libspice-server-dev": "0.12.6-4ubuntu0.5"
        }
    ]
}