USN-4634-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4634-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4634-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4634-1
Related
Published
2020-11-17T13:10:04.805223Z
Modified
2020-11-17T13:10:04.805223Z
Summary
openldap vulnerabilities
Details

It was discovered that OpenLDAP incorrectly handled certain malformed inputs. A remote attacker could possibly use this issue to cause OpenLDAP to crash, resulting in a denial of service.

References

Affected packages

Ubuntu:20.04:LTS / openldap

Package

Name
openldap

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.49+dfsg-2ubuntu1.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "slapd-contrib": "2.4.49+dfsg-2ubuntu1.5",
            "slapi-dev": "2.4.49+dfsg-2ubuntu1.5",
            "libldap2-dev": "2.4.49+dfsg-2ubuntu1.5",
            "libldap-2.4-2": "2.4.49+dfsg-2ubuntu1.5",
            "libldap-common": "2.4.49+dfsg-2ubuntu1.5",
            "slapd": "2.4.49+dfsg-2ubuntu1.5",
            "slapd-smbk5pwd": "2.4.49+dfsg-2ubuntu1.5",
            "ldap-utils": "2.4.49+dfsg-2ubuntu1.5"
        }
    ]
}

Ubuntu:18.04:LTS / openldap

Package

Name
openldap

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.45+dfsg-1ubuntu1.8

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "slapd-smbk5pwd": "2.4.45+dfsg-1ubuntu1.8",
            "libldap-common": "2.4.45+dfsg-1ubuntu1.8",
            "libldap-2.4-2": "2.4.45+dfsg-1ubuntu1.8",
            "slapd": "2.4.45+dfsg-1ubuntu1.8",
            "libldap2-dev": "2.4.45+dfsg-1ubuntu1.8",
            "ldap-utils": "2.4.45+dfsg-1ubuntu1.8"
        }
    ]
}

Ubuntu:16.04:LTS / openldap

Package

Name
openldap

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.42+dfsg-2ubuntu3.11

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libldap-2.4-2": "2.4.42+dfsg-2ubuntu3.11",
            "libldap2-dev": "2.4.42+dfsg-2ubuntu3.11",
            "slapd": "2.4.42+dfsg-2ubuntu3.11",
            "slapd-smbk5pwd": "2.4.42+dfsg-2ubuntu3.11",
            "ldap-utils": "2.4.42+dfsg-2ubuntu3.11"
        }
    ]
}