USN-4640-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4640-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4640-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4640-1
Related
  • CVE-2020-16123
Published
2020-11-23T16:03:54.346501Z
Modified
2020-11-23T16:03:54.346501Z
Summary
pulseaudio vulnerability
Details

James Henstridge discovered that an Ubuntu-specific patch caused PulseAudio to incorrectly handle snap client connections. An attacker could possibly use this to expose sensitive information.

References

Affected packages

Ubuntu:20.04:LTS / pulseaudio

Package

Name
pulseaudio

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:13.99.1-1ubuntu3.8

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libpulse-dev": "1:13.99.1-1ubuntu3.8",
            "pulseaudio-utils": "1:13.99.1-1ubuntu3.8",
            "pulseaudio-equalizer": "1:13.99.1-1ubuntu3.8",
            "pulseaudio-module-raop": "1:13.99.1-1ubuntu3.8",
            "pulseaudio-module-zeroconf": "1:13.99.1-1ubuntu3.8",
            "pulseaudio-module-gsettings": "1:13.99.1-1ubuntu3.8",
            "pulseaudio": "1:13.99.1-1ubuntu3.8",
            "libpulse0": "1:13.99.1-1ubuntu3.8",
            "pulseaudio-module-jack": "1:13.99.1-1ubuntu3.8",
            "libpulsedsp": "1:13.99.1-1ubuntu3.8",
            "pulseaudio-module-lirc": "1:13.99.1-1ubuntu3.8",
            "pulseaudio-module-bluetooth": "1:13.99.1-1ubuntu3.8",
            "libpulse-mainloop-glib0": "1:13.99.1-1ubuntu3.8"
        }
    ]
}

Ubuntu:18.04:LTS / pulseaudio

Package

Name
pulseaudio

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:11.1-1ubuntu7.11

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libpulse-dev": "1:11.1-1ubuntu7.11",
            "pulseaudio-module-raop": "1:11.1-1ubuntu7.11",
            "pulseaudio-module-gconf": "1:11.1-1ubuntu7.11",
            "pulseaudio-module-zeroconf": "1:11.1-1ubuntu7.11",
            "libpulse0": "1:11.1-1ubuntu7.11",
            "pulseaudio-esound-compat": "1:11.1-1ubuntu7.11",
            "pulseaudio-utils": "1:11.1-1ubuntu7.11",
            "pulseaudio-equalizer": "1:11.1-1ubuntu7.11",
            "libpulse-mainloop-glib0": "1:11.1-1ubuntu7.11",
            "pulseaudio-module-bluetooth": "1:11.1-1ubuntu7.11",
            "pulseaudio": "1:11.1-1ubuntu7.11",
            "pulseaudio-module-jack": "1:11.1-1ubuntu7.11",
            "libpulsedsp": "1:11.1-1ubuntu7.11",
            "pulseaudio-module-lirc": "1:11.1-1ubuntu7.11"
        }
    ]
}

Ubuntu:16.04:LTS / pulseaudio

Package

Name
pulseaudio

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:8.0-0ubuntu3.15

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libpulse-dev": "1:8.0-0ubuntu3.15",
            "pulseaudio-module-raop": "1:8.0-0ubuntu3.15",
            "pulseaudio-module-gconf": "1:8.0-0ubuntu3.15",
            "pulseaudio-module-zeroconf": "1:8.0-0ubuntu3.15",
            "libpulse0": "1:8.0-0ubuntu3.15",
            "pulseaudio-module-x11": "1:8.0-0ubuntu3.15",
            "pulseaudio-esound-compat": "1:8.0-0ubuntu3.15",
            "pulseaudio-module-droid": "1:8.0-0ubuntu3.15",
            "pulseaudio-utils": "1:8.0-0ubuntu3.15",
            "pulseaudio-module-bluetooth": "1:8.0-0ubuntu3.15",
            "libpulse-mainloop-glib0": "1:8.0-0ubuntu3.15",
            "pulseaudio": "1:8.0-0ubuntu3.15",
            "pulseaudio-module-jack": "1:8.0-0ubuntu3.15",
            "pulseaudio-module-trust-store": "1:8.0-0ubuntu3.15",
            "libpulsedsp": "1:8.0-0ubuntu3.15",
            "pulseaudio-module-lirc": "1:8.0-0ubuntu3.15"
        }
    ]
}