USN-4642-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4642-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4642-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4642-1
Related
Published
2020-11-24T00:22:17.908756Z
Modified
2020-11-24T00:22:17.908756Z
Summary
pdfresurrect vulnerability
Details

It was discovered that PDFResurrect incorrectly handled certain memory operations during PDF summary generation. An attacker could use this to cause out-of-bounds writes, resulting in a denial of service (system crash) or arbitrary code execution.

References

Affected packages

Ubuntu:16.04:LTS / pdfresurrect

Package

Name
pdfresurrect

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.12-6ubuntu0.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "pdfresurrect": "0.12-6ubuntu0.2"
        }
    ]
}