USN-4695-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4695-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4695-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4695-1
Related
Published
2021-01-18T12:30:38.357335Z
Modified
2021-01-18T12:30:38.357335Z
Summary
icoutils vulnerabilities
Details

Choongwoo Han discovered that icoutils incorrectly handled certain files. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2017-5208)

It was discovered that icoutils incorrectly handled certain files. An attacker could possibly use this issue to cause a denial of service or execute arbitrary code. (CVE-2017-5331, CVE-2017-5332, CVE-2017-5333)

Jerzy Kramarz discovered that icoutils incorrectly handled certain files. An attacker could possibly use this issue to cause a crash or execute arbitrary code. (CVE-2017-6009, CVE-2017-6010)

Jerzy Kramarz discovered that icoutils incorrectly handled certain files. An attacker could possibly use this issue to expose sensitive information. (CVE-2017-6011)

References

Affected packages

Ubuntu:16.04:LTS / icoutils

Package

Name
icoutils

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.31.0-3ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "icoutils": "0.31.0-3ubuntu0.1"
        }
    ]
}