USN-4754-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-4754-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4754-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4754-2
Published
2021-02-25T18:54:00.752615Z
Modified
2021-02-25T18:54:00.752615Z
Summary
python2.7 regression
Details

USN-4754-1 fixed a vulnerability in Python. The fix for CVE-2021-3177 introduced a regression in Python 2.7. This update reverts the security fix pending further investigation.

We apologize for the inconvenience.

Original advisory details:

It was discovered that Python incorrectly handled certain inputs. An attacker could possibly use this issue to execute arbitrary code or cause a denial of service. (CVE-2020-27619, CVE-2021-3177)

References

Affected packages

Ubuntu:Pro:14.04:LTS / python2.7

Package

Name
python2.7

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.7.6-8ubuntu0.6+esm9

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "python2.7": "2.7.6-8ubuntu0.6+esm9",
            "libpython2.7": "2.7.6-8ubuntu0.6+esm9",
            "libpython2.7-stdlib": "2.7.6-8ubuntu0.6+esm9",
            "python2.7-dev": "2.7.6-8ubuntu0.6+esm9",
            "python2.7-examples": "2.7.6-8ubuntu0.6+esm9",
            "python2.7-doc": "2.7.6-8ubuntu0.6+esm9",
            "idle-python2.7": "2.7.6-8ubuntu0.6+esm9",
            "libpython2.7-testsuite": "2.7.6-8ubuntu0.6+esm9",
            "python2.7-minimal": "2.7.6-8ubuntu0.6+esm9",
            "libpython2.7-dev": "2.7.6-8ubuntu0.6+esm9",
            "libpython2.7-minimal": "2.7.6-8ubuntu0.6+esm9"
        }
    ]
}

Ubuntu:18.04:LTS / python2.7

Package

Name
python2.7

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.7.17-1~18.04ubuntu1.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python2.7": "2.7.17-1~18.04ubuntu1.5",
            "libpython2.7": "2.7.17-1~18.04ubuntu1.5",
            "libpython2.7-stdlib": "2.7.17-1~18.04ubuntu1.5",
            "python2.7-dev": "2.7.17-1~18.04ubuntu1.5",
            "python2.7-examples": "2.7.17-1~18.04ubuntu1.5",
            "python2.7-doc": "2.7.17-1~18.04ubuntu1.5",
            "idle-python2.7": "2.7.17-1~18.04ubuntu1.5",
            "libpython2.7-testsuite": "2.7.17-1~18.04ubuntu1.5",
            "python2.7-minimal": "2.7.17-1~18.04ubuntu1.5",
            "libpython2.7-dev": "2.7.17-1~18.04ubuntu1.5",
            "libpython2.7-minimal": "2.7.17-1~18.04ubuntu1.5"
        }
    ]
}

Ubuntu:16.04:LTS / python2.7

Package

Name
python2.7

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.7.12-1ubuntu0~16.04.16

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python2.7": "2.7.12-1ubuntu0~16.04.16",
            "libpython2.7": "2.7.12-1ubuntu0~16.04.16",
            "libpython2.7-stdlib": "2.7.12-1ubuntu0~16.04.16",
            "python2.7-dev": "2.7.12-1ubuntu0~16.04.16",
            "python2.7-examples": "2.7.12-1ubuntu0~16.04.16",
            "python2.7-doc": "2.7.12-1ubuntu0~16.04.16",
            "idle-python2.7": "2.7.12-1ubuntu0~16.04.16",
            "libpython2.7-testsuite": "2.7.12-1ubuntu0~16.04.16",
            "python2.7-minimal": "2.7.12-1ubuntu0~16.04.16",
            "libpython2.7-dev": "2.7.12-1ubuntu0~16.04.16",
            "libpython2.7-minimal": "2.7.12-1ubuntu0~16.04.16"
        }
    ]
}