USN-4771-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4771-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4771-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4771-1
Related
Published
2021-03-15T20:14:57.908073Z
Modified
2021-03-15T20:14:57.908073Z
Summary
condor vulnerabilities
Details

It was discovered that HTCondor incorrectly invoked the mailx utility. An attacker could use this vulnerability to execute arbitrary commands. This issue only affected Ubuntu 14.04 ESM. (CVE-2014-8126)

It was discovered that HTCondor mishandled certain crafted input. An attacker could use this vulnerability to cause HTCondor to crash. (CVE-2017-16816)

References

Affected packages

Ubuntu:Pro:14.04:LTS / condor

Package

Name
condor

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8.0.5~dfsg.1-1ubuntu1+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "htcondor": "8.0.5~dfsg.1-1ubuntu1+esm1",
            "libclassad-dev": "8.0.5~dfsg.1-1ubuntu1+esm1",
            "htcondor-dev": "8.0.5~dfsg.1-1ubuntu1+esm1",
            "htcondor-doc": "8.0.5~dfsg.1-1ubuntu1+esm1",
            "libclassad5": "8.0.5~dfsg.1-1ubuntu1+esm1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / condor

Package

Name
condor

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
8.4.2~dfsg.1-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "condor-doc": "8.4.2~dfsg.1-1ubuntu0.1~esm1",
            "libclassad7": "8.4.2~dfsg.1-1ubuntu0.1~esm1",
            "libclassad-dev": "8.4.2~dfsg.1-1ubuntu0.1~esm1",
            "condor-dev": "8.4.2~dfsg.1-1ubuntu0.1~esm1",
            "htcondor": "8.4.2~dfsg.1-1ubuntu0.1~esm1",
            "htcondor-dev": "8.4.2~dfsg.1-1ubuntu0.1~esm1",
            "htcondor-doc": "8.4.2~dfsg.1-1ubuntu0.1~esm1",
            "condor": "8.4.2~dfsg.1-1ubuntu0.1~esm1"
        }
    ]
}