USN-4795-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4795-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4795-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4795-1
Related
Published
2021-03-15T21:16:37.627783Z
Modified
2021-03-15T21:16:37.627783Z
Summary
groovy2 vulnerability
Details

It was discovered that Apache Groovy incorrectly handled serialization mechanisms. An attacker could possibly use this issue to execute arbitrary code.

References

Affected packages

Ubuntu:Pro:16.04:LTS / groovy2

Package

Name
groovy2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.5-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "groovy2": "2.4.5-1ubuntu0.1~esm1",
            "groovy2-doc": "2.4.5-1ubuntu0.1~esm1"
        }
    ]
}