USN-4822-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4822-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4822-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4822-1
Related
  • CVE-2017-6369
Published
2021-03-15T22:00:01.987479Z
Modified
2021-03-15T22:00:01.987479Z
Summary
firebird2.5 vulnerability
Details

It was discovered that Firebird exposed certain UDF libraries. An authenticated attacker could use this vulnerability to cause a denial of service (crash) or possibly execute arbitrary code.

References

Affected packages

Ubuntu:Pro:16.04:LTS / firebird2.5

Package

Name
firebird2.5

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.5.4.26856.ds4-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "firebird2.5-doc": "2.5.4.26856.ds4-1ubuntu0.1~esm1",
            "firebird2.5-examples": "2.5.4.26856.ds4-1ubuntu0.1~esm1",
            "firebird-dev": "2.5.4.26856.ds4-1ubuntu0.1~esm1",
            "firebird2.5-server-common": "2.5.4.26856.ds4-1ubuntu0.1~esm1",
            "firebird2.5-common": "2.5.4.26856.ds4-1ubuntu0.1~esm1",
            "firebird2.5-classic": "2.5.4.26856.ds4-1ubuntu0.1~esm1",
            "firebird2.5-common-doc": "2.5.4.26856.ds4-1ubuntu0.1~esm1",
            "firebird2.5-classic-common": "2.5.4.26856.ds4-1ubuntu0.1~esm1",
            "libfbclient2": "2.5.4.26856.ds4-1ubuntu0.1~esm1",
            "firebird2.5-superclassic": "2.5.4.26856.ds4-1ubuntu0.1~esm1",
            "libib-util": "2.5.4.26856.ds4-1ubuntu0.1~esm1",
            "firebird2.5-super": "2.5.4.26856.ds4-1ubuntu0.1~esm1",
            "libfbembed2.5": "2.5.4.26856.ds4-1ubuntu0.1~esm1"
        }
    ]
}