USN-4880-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4880-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4880-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4880-1
Related
Published
2021-03-16T10:32:18.251827Z
Modified
2021-03-16T10:32:18.251827Z
Summary
openjpeg2 vulnerabilities
Details

It was discovered that OpenJPEG incorrectly handled certain image data. An attacker could use this issue to cause OpenJPEG to crash, leading to a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:16.04:LTS / openjpeg2

Package

Name
openjpeg2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.1.2-1.1+deb9u6build0.16.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libopenjp2-7": "2.1.2-1.1+deb9u6build0.16.04.1",
            "libopenjpip-server": "2.1.2-1.1+deb9u6build0.16.04.1",
            "libopenjp2-tools": "2.1.2-1.1+deb9u6build0.16.04.1",
            "libopenjp2-7-dev": "2.1.2-1.1+deb9u6build0.16.04.1",
            "libopenjpip7": "2.1.2-1.1+deb9u6build0.16.04.1",
            "libopenjp3d7": "2.1.2-1.1+deb9u6build0.16.04.1",
            "libopenjp3d-tools": "2.1.2-1.1+deb9u6build0.16.04.1",
            "libopenjpip-dec-server": "2.1.2-1.1+deb9u6build0.16.04.1",
            "libopenjpip-viewer": "2.1.2-1.1+deb9u6build0.16.04.1"
        }
    ]
}