USN-4902-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4902-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4902-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4902-1
Related
Published
2021-04-06T10:56:20.390080Z
Modified
2021-04-06T10:56:20.390080Z
Summary
python-django vulnerability
Details

Dennis Brinkrolf discovered that Django incorrectly handled certain filenames. A remote attacker could possibly use this issue to create or overwrite files in unexpected directories.

References

Affected packages

Ubuntu:20.04:LTS / python-django

Package

Name
python-django

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:2.2.12-1ubuntu0.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python-django-doc": "2:2.2.12-1ubuntu0.5",
            "python3-django": "2:2.2.12-1ubuntu0.5"
        }
    ]
}

Ubuntu:18.04:LTS / python-django

Package

Name
python-django

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:1.11.11-1ubuntu1.12

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python-django-common": "1:1.11.11-1ubuntu1.12",
            "python-django-doc": "1:1.11.11-1ubuntu1.12",
            "python-django": "1:1.11.11-1ubuntu1.12",
            "python3-django": "1:1.11.11-1ubuntu1.12"
        }
    ]
}

Ubuntu:16.04:LTS / python-django

Package

Name
python-django

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.8.7-1ubuntu5.15

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python-django-common": "1.8.7-1ubuntu5.15",
            "python-django-doc": "1.8.7-1ubuntu5.15",
            "python-django": "1.8.7-1ubuntu5.15",
            "python3-django": "1.8.7-1ubuntu5.15"
        }
    ]
}