USN-4957-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4957-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4957-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4957-1
Related
  • CVE-2021-32490
  • CVE-2021-32491
  • CVE-2021-32492
  • CVE-2021-32493
  • CVE-2021-3500
Published
2021-05-17T17:11:40.449051Z
Modified
2021-05-17T17:11:40.449051Z
Summary
djvulibre vulnerabilities
Details

It was discovered that DjVuLibre incorrectly handled certain memory operations. If a user or automated system were tricked into processing a specially crafted DjVu file, a remote attacker could cause applications to hang or crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:18.04:LTS / djvulibre

Package

Name
djvulibre

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.5.27.1-8ubuntu0.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "djview3": "3.5.27.1-8ubuntu0.3",
            "libdjvulibre21": "3.5.27.1-8ubuntu0.3",
            "djvulibre-bin": "3.5.27.1-8ubuntu0.3",
            "djvulibre-desktop": "3.5.27.1-8ubuntu0.3",
            "libdjvulibre-text": "3.5.27.1-8ubuntu0.3",
            "djvuserve": "3.5.27.1-8ubuntu0.3",
            "djview": "3.5.27.1-8ubuntu0.3",
            "libdjvulibre-dev": "3.5.27.1-8ubuntu0.3"
        }
    ]
}

Ubuntu:20.04:LTS / djvulibre

Package

Name
djvulibre

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.5.27.1-14ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "djview3": "3.5.27.1-14ubuntu0.1",
            "libdjvulibre21": "3.5.27.1-14ubuntu0.1",
            "djvulibre-bin": "3.5.27.1-14ubuntu0.1",
            "djvulibre-desktop": "3.5.27.1-14ubuntu0.1",
            "libdjvulibre-text": "3.5.27.1-14ubuntu0.1",
            "djvuserve": "3.5.27.1-14ubuntu0.1",
            "djview": "3.5.27.1-14ubuntu0.1",
            "libdjvulibre-dev": "3.5.27.1-14ubuntu0.1"
        }
    ]
}