USN-4962-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-4962-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-4962-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-4962-1
Related
  • CVE-2021-20095
Published
2021-05-19T14:00:33.064910Z
Modified
2021-05-19T14:00:33.064910Z
Summary
python-babel vulnerability
Details

It was discovered that Babel incorrectly handled certain inputs. An attacker could possibly use this issue to execute arbitrary code.

References

Affected packages

Ubuntu:Pro:14.04:LTS / python-babel

Package

Name
python-babel

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.3+dfsg.1-2ubuntu2+esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "python-babel-doc": "1.3+dfsg.1-2ubuntu2+esm1",
            "python-babel": "1.3+dfsg.1-2ubuntu2+esm1",
            "python3-babel": "1.3+dfsg.1-2ubuntu2+esm1",
            "python-pybabel": "1.3+dfsg.1-2ubuntu2+esm1",
            "python-babel-localedata": "1.3+dfsg.1-2ubuntu2+esm1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / python-babel

Package

Name
python-babel

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.3+dfsg.1-6ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "python-babel-doc": "1.3+dfsg.1-6ubuntu0.1~esm1",
            "python-babel": "1.3+dfsg.1-6ubuntu0.1~esm1",
            "python3-babel": "1.3+dfsg.1-6ubuntu0.1~esm1",
            "python-pybabel": "1.3+dfsg.1-6ubuntu0.1~esm1",
            "python-babel-localedata": "1.3+dfsg.1-6ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:18.04:LTS / python-babel

Package

Name
python-babel

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.0+dfsg.1-2ubuntu1.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python-babel-doc": "2.4.0+dfsg.1-2ubuntu1.1",
            "python-babel": "2.4.0+dfsg.1-2ubuntu1.1",
            "python3-babel": "2.4.0+dfsg.1-2ubuntu1.1",
            "python-babel-localedata": "2.4.0+dfsg.1-2ubuntu1.1"
        }
    ]
}

Ubuntu:20.04:LTS / python-babel

Package

Name
python-babel

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.6.0+dfsg.1-1ubuntu2.2

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "python-babel-doc": "2.6.0+dfsg.1-1ubuntu2.2",
            "python-babel": "2.6.0+dfsg.1-1ubuntu2.2",
            "python3-babel": "2.6.0+dfsg.1-1ubuntu2.2",
            "python-babel-localedata": "2.6.0+dfsg.1-1ubuntu2.2"
        }
    ]
}